Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Removed numpy deprecation warnings #362

Open
scopatz opened this Issue · 8 comments

2 participants

@crbates
Owner

I seem to remember spending about an hour trying to get this to work for the cython files when working on #221/#222 without any success. I think this has to be done upstream in cython, but I could be wrong.

@scopatz
Owner

I seem to recall that as well. I'll look into it.

@scopatz
Owner

So I can turn off the old API with adding the following in CMakeLists:

add_definitions(-DNPY_NO_DEPRECATED_API=NPY_1_7_API_VERSION)

but then the build fails because Cython is using the old API!

@scopatz scopatz added this to the v0.5 milestone
@scopatz
Owner

This can be done by removing the string from the cxx files that are generated by cython.

@crbates
Owner

@scopatz do we want to add a sed command to do this in the build?

@scopatz
Owner

I think so. It would be nice. It might be tricky though, because we'd have to copy some of the cython files over locally.

@scopatz
Owner

I'd be fine with moving this to v0.6, too.

@crbates crbates modified the milestone: v0.6, v0.5
@crbates
Owner

yuck, 0.6 it is.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.