Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Incompatible version of pyparsing not restricted in #91

Lehych opened this issue Jan 25, 2017 · 3 comments · Fixed by #103

Incompatible version of pyparsing not restricted in #91

Lehych opened this issue Jan 25, 2017 · 3 comments · Fixed by #103


Copy link

Lehych commented Jan 25, 2017

To reproduce do the following
virtualenv venv && venv/bin/pip install pyparsing==2.0.1 && venv/bin/pip install packaging==16.3 && venv/bin/python -c "import packaging.requirements"
youll get

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "venv/local/lib/python2.7/site-packages/packaging/", line 59, in <module>
    MARKER_EXPR = originalTextFor(MARKER_EXPR())("marker")
TypeError: __call__() takes exactly 2 arguments (1 given)

In pyparsing it was fixed here: (v 2.0.2)

Copy link

jaraco commented Jan 28, 2017

This issue is much more pressing now that setuptools 34 depends on packaging and pyparsing rather than vendoring them. If something else in the environment has installed an older version of pyparsing, import of pkg_resources will trigger this error.

Copy link

Yep, this has broken some of our core tooling. It's a pretty serious issue.

Copy link

This bug results in the latest available python3-pip (and likely python3-setuptool) for Ubuntu 14.04LTS to be broken during normal package upgrade. I opened a ticket for the package maintainer side, but they are likely depending on a solution here.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
None yet
None yet

Successfully merging a pull request may close this issue.

4 participants