Permalink
Browse files

update changelog with note about case where distribute upgrade can fail

  • Loading branch information...
1 parent a1fa1ae commit 0e342bc1297a4fde6d622d0f152161f3cbae9162 @qwcode qwcode committed Jul 6, 2013
Showing with 11 additions and 1 deletion.
  1. +9 −1 CHANGES.txt
  2. +2 −0 docs/installing.rst
View
10 CHANGES.txt
@@ -1,13 +1,21 @@
Changelog
=========
-1.4.dev1 (unreleased)
+1.4 (unreleased)
---------------------
* To satisfy pip's setuptools requirement, pip now recommends setuptools>=0.8,
not distribute. setuptools and distribute are now merged into one project called
'setuptools'. (Pull #1003)
+ .. note::
+
+ Although older pip versions can successfully :ref:`upgrade distribute or
+ setuptools to the new merged setuptools <Installation Requirements>`, there
+ `are cases where the upgrade can fail
+ <https://github.com/pypa/pip/issues/1033#issuecomment-20546202>`_ if it
+ occurs in the context of package upgrade that depends on distribute.
+
* If an already-downloaded or cached file has a bad hash, re-download it rather
than erroring out. (Issue #963).
View
2 docs/installing.rst
@@ -53,6 +53,8 @@ Often this requires the installation to be performed as root.
We advise against using `easy_install <http://pythonhosted.org/setuptools/easy_install.html>`_ to install pip, because easy_install
does not download from PyPI over SSL, so the installation might be insecure.
+.. _`Installation Requirements`:
+
Requirements
++++++++++++

0 comments on commit 0e342bc

Please sign in to comment.