Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

pip 10 fails to install dependency specified in pyproject.toml #5244

Closed
lazka opened this issue Apr 15, 2018 · 6 comments
Closed

pip 10 fails to install dependency specified in pyproject.toml #5244

lazka opened this issue Apr 15, 2018 · 6 comments

Comments

@lazka
Copy link
Contributor

@lazka lazka commented Apr 15, 2018

The package PyGObject (pre-release) contains the following pyproject.toml:

[build-system]
requires = ["setuptools", "wheel", "pycairo"]

Steps:

  • pip install pygobject --pre

Expected:

  • pip installs pycairo and then pygobject

Actual:

> pip install pycairo                  
Requirement already satisfied: pycairo in ./foo/lib/python3.6/site-packages (1.17.0)
> pip install pygobject --pre 
Collecting pygobject
  Using cached PyGObject-3.29.1.dev0.tar.gz
  Could not find a version that satisfies the requirement pycairo (from versions: )
No matching distribution found for pycairo
@pfmoore
Copy link
Member

@pfmoore pfmoore commented Apr 15, 2018

pycairo doesn't support installing PEP 518 dependencies from source (yet). See https://pip.pypa.io/en/latest/reference/pip/#pep-518-support which explains the current limitations of pip's PEP 518 support.

@lazka
Copy link
Contributor Author

@lazka lazka commented Apr 15, 2018

Thanks, I see. Providing wheels for pycairo is a bit hard because it links against other libraries with varying build configuration.

In my example above pip did build a wheel for pycairo first, so it wouldn't have to build from source theoretically.

Feel free to close this.

gnomesysadmins pushed a commit to GNOME/pygobject that referenced this issue Apr 15, 2018
This reverts commit b4ff233.

pip 10 can only install wheel dependencies, which we don't have.
pypa/pip#5244
@jackton1
Copy link

@jackton1 jackton1 commented Apr 16, 2018

Temporary Fix

Upgrade pip using.

curl https://bootstrap.pypa.io/get-pip.py | python3

Instead of pip install -U pip

@lazka
Copy link
Contributor Author

@lazka lazka commented Apr 16, 2018

@lazka
Copy link
Contributor Author

@lazka lazka commented Apr 25, 2018

Closing as a duplicate of #5229

@lazka lazka closed this Apr 25, 2018
@lock
Copy link

@lock lock bot commented Jun 2, 2019

This thread has been automatically locked since there has not been any recent activity after it was closed. Please open a new issue for related bugs.

@lock lock bot added the S: auto-locked label Jun 2, 2019
@lock lock bot locked as resolved and limited conversation to collaborators Jun 2, 2019
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants