Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade Sphinx version for Read the Docs #6471

Closed
brainwane opened this issue May 7, 2019 · 2 comments · Fixed by #6477
Closed

Upgrade Sphinx version for Read the Docs #6471

brainwane opened this issue May 7, 2019 · 2 comments · Fixed by #6477
Labels
good first issue S: auto-locked type: docs

Comments

@brainwane
Copy link
Member

@brainwane brainwane commented May 7, 2019

What's the problem this feature will solve?
The pip documentation says in the footer: "Created using Sphinx 1.7.9." The Sphinx website says the latest version of Sphinx is 2.0.1.

Describe the solution you'd like
Update the dependency at tools/docs-requirements.txt so it pins to Sphinx 2.0.1, not sphinx == 1.7.*.

I believe one of the maintainers of the pip project on Read the Docs might also need to log in and fiddle with the preferred version of Sphinx to get things to work right.

@cjerdonek cjerdonek added the type: docs label May 7, 2019
@dstufft dstufft added the good first issue label May 7, 2019
@ppiyakk2
Copy link
Contributor

@ppiyakk2 ppiyakk2 commented May 7, 2019

I will working on it!

@ppiyakk2
Copy link
Contributor

@ppiyakk2 ppiyakk2 commented May 7, 2019

The sphinx version 2.0.1 doesn't accept python 2.7. It support over python 3.5.

This is the result of command pip install sphinx==2.0.1 -v

The package https://files.pythonhosted.org/packages/81/e3/cb726b65039569840547895e1c81759d44e50512d038268afa8c1bf2001c/Sphinx-2.0.1.tar.gz#sha256=423280646fb37944dd3c85c58fb92a20d745793a9f6c511f59da82fa97cd404b (from https://pypi.org/simple/sphinx/) (requires-python:>=3.5) is incompatible with the pythonversion in use. Acceptable python versions are:>=3.5
  Could not find a version that satisfies the requirement Sphinx==2.0.1 (from versions: 0.1.61611, 0.1.61798, 0.1.61843, 0.1.61945, 0.1.61950, 0.2, 0.3, 0.4, 0.4.1, 0.4.2, 0.4.3, 0.5, 0.5.1, 0.5.2b1, 0.5.2, 0.6b1, 0.6, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5, 0.6.6, 0.6.7, 1.0b1, 1.0b2, 1.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.1, 1.1.1, 1.1.2, 1.1.3, 1.2b1, 1.2b2, 1.2b3, 1.2, 1.2.1, 1.2.2, 1.2.3, 1.3b1, 1.3b2, 1.3b3, 1.3, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.3.6, 1.4a1, 1.4b1, 1.4, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.5, 1.4.6, 1.4.7, 1.4.8, 1.4.9, 1.5a1, 1.5a2, 1.5b1, 1.5, 1.5.1, 1.5.2, 1.5.3, 1.5.4, 1.5.5, 1.5.6, 1.6b1, 1.6b2, 1.6b3, 1.6.1, 1.6.2, 1.6.3, 1.6.4, 1.6.5, 1.6.6, 1.6.7, 1.7.0b1, 1.7.0b2, 1.7.0, 1.7.1, 1.7.2, 1.7.3, 1.7.4, 1.7.5, 1.7.6, 1.7.7, 1.7.8, 1.7.9, 1.8.0b1, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5)

@lock lock bot added the S: auto-locked label Jun 7, 2019
@lock lock bot locked as resolved and limited conversation to collaborators Jun 7, 2019
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
good first issue S: auto-locked type: docs
Projects
None yet
Development

Successfully merging a pull request may close this issue.

4 participants