New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

pip list outdated #933

Closed
pratz opened this Issue May 6, 2013 · 2 comments

Comments

Projects
None yet
3 participants
@pratz

pratz commented May 6, 2013

I install Flask version 0.8 with pip in editable mode

pip install -e git+https://github.com/mitsuhiko/flask.git@0.8#egg=flask

Output of pip list

argparse (1.2.1)
Flask (0.8dev-20130506, /home/pratz/VirtualEnv/learnflask/src/flask)
Jinja2 (2.6)
Werkzeug (0.8.3)
wsgiref (0.1.2)

Ouput of pip list -o
Nothing ( returns to console without any output )

Should not the output of pip list -o be
Flask (Current: 0.8dev Latest: 0.9)

Or is this how pip list -o works for editable mode ?

NOTE: pip version is 1.3.1

@janfabry

This comment has been minimized.

Show comment
Hide comment
@janfabry

janfabry May 27, 2013

Editable packages are not included in the outdated list. I don't know whether there is an issue open for that, because I would like that functionality (but it's not an easy one to spec).

janfabry commented May 27, 2013

Editable packages are not included in the outdated list. I don't know whether there is an issue open for that, because I would like that functionality (but it's not an easy one to spec).

@xavfernandez

This comment has been minimized.

Show comment
Hide comment
@xavfernandez

xavfernandez Oct 9, 2015

Contributor

This comes from #752 but I see no reason the options --outdated and --editable could not be combined.

Contributor

xavfernandez commented Oct 9, 2015

This comes from #752 but I see no reason the options --outdated and --editable could not be combined.

xavfernandez added a commit to xavfernandez/pip that referenced this issue Oct 10, 2015

Allow combination of pip list options
--editable with --outdated/--updtodate
closes pypa#933

xavfernandez added a commit to xavfernandez/pip that referenced this issue Oct 22, 2015

Allow combination of pip list options
--editable with --outdated/--updtodate
closes pypa#933

xavfernandez added a commit to xavfernandez/pip that referenced this issue Oct 28, 2015

Allow combination of pip list options
--editable with --outdated/--updtodate
closes pypa#933

xavfernandez added a commit to xavfernandez/pip that referenced this issue Oct 28, 2015

Allow combination of pip list options
--editable with --outdated/--updtodate
closes pypa#933

xavfernandez added a commit to xavfernandez/pip that referenced this issue Nov 13, 2015

Allow combination of pip list options
--editable with --outdated/--updtodate
closes pypa#933
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment