New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix up the bundle support #1116

Merged
merged 1 commit into from Aug 7, 2013

Conversation

Projects
None yet
2 participants
@qwcode
Contributor

qwcode commented Aug 7, 2013

fix for #1114

the bundle support had 2 tests before (just for "pip bundle", not for installing bundles), now it has 3, including one for installing bundles.

@qwcode

This comment has been minimized.

Show comment
Hide comment
@qwcode

qwcode Aug 7, 2013

Contributor

@ionelmc, @nOw2 feel free to try.

Contributor

qwcode commented Aug 7, 2013

@ionelmc, @nOw2 feel free to try.

@ionelmc

This comment has been minimized.

Show comment
Hide comment
@ionelmc

ionelmc Aug 7, 2013

Contributor

It appears to work. I've did this:

rm -rf /environment || echo OK
virtualenv /environment --system-site-package
/environment/bin/easy_install https://github.com/qwcode/pip/archive/fix_bundle.zip
/environment/bin/pip install --force-reinstall --ignore-installed deps.zip

Strangely enough if I try:

rm -rf /environment || echo OK
virtualenv /environment --system-site-package
/environment/bin/pip install https://github.com/qwcode/pip/archive/fix_bundle.zip
/environment/bin/pip install --force-reinstall --ignore-installed deps.zip

it doesn't work (cause pip doesn't get upgraded). Is that expected behavior ?

Note for @nOw2: virtualenv 1.10 will bundle the broken pip-1.4, you might want to downgrade virtualenv too.

Contributor

ionelmc commented Aug 7, 2013

It appears to work. I've did this:

rm -rf /environment || echo OK
virtualenv /environment --system-site-package
/environment/bin/easy_install https://github.com/qwcode/pip/archive/fix_bundle.zip
/environment/bin/pip install --force-reinstall --ignore-installed deps.zip

Strangely enough if I try:

rm -rf /environment || echo OK
virtualenv /environment --system-site-package
/environment/bin/pip install https://github.com/qwcode/pip/archive/fix_bundle.zip
/environment/bin/pip install --force-reinstall --ignore-installed deps.zip

it doesn't work (cause pip doesn't get upgraded). Is that expected behavior ?

Note for @nOw2: virtualenv 1.10 will bundle the broken pip-1.4, you might want to downgrade virtualenv too.

@qwcode

This comment has been minimized.

Show comment
Hide comment
@qwcode

qwcode Aug 7, 2013

Contributor

@ionelmc what doesn't work? what is deps.zip? when I ran pip install https://github.com/qwcode/pip/archive/fix_bundle.zip, pip got upgraded (from 1.3.1 in my case)

Contributor

qwcode commented Aug 7, 2013

@ionelmc what doesn't work? what is deps.zip? when I ran pip install https://github.com/qwcode/pip/archive/fix_bundle.zip, pip got upgraded (from 1.3.1 in my case)

@ionelmc

This comment has been minimized.

Show comment
Hide comment
@ionelmc

ionelmc Aug 7, 2013

Contributor

I think it's fine, I had 1.4.0 installed and https://github.com/qwcode/pip/archive/fix_bundle.zip declared the same version - thus didn't get upgraded. But it kinds breaks the expectation that if you would specify a direct url instead of package name you'll get upgrade/reinstall behavior (eg: pip install -I -U). This is totally different issue however.

Contributor

ionelmc commented Aug 7, 2013

I think it's fine, I had 1.4.0 installed and https://github.com/qwcode/pip/archive/fix_bundle.zip declared the same version - thus didn't get upgraded. But it kinds breaks the expectation that if you would specify a direct url instead of package name you'll get upgrade/reinstall behavior (eg: pip install -I -U). This is totally different issue however.

@ionelmc

This comment has been minimized.

Show comment
Hide comment
@ionelmc

ionelmc Aug 7, 2013

Contributor

@qwcode deps.zip is just a pybundle zip

Contributor

ionelmc commented Aug 7, 2013

@qwcode deps.zip is just a pybundle zip

qwcode added a commit that referenced this pull request Aug 7, 2013

@qwcode qwcode merged commit cbfe4e0 into pypa:1.4.X Aug 7, 2013

1 check failed

default The Travis CI build failed
Details

@qwcode qwcode referenced this pull request Aug 7, 2013

Closed

pip bundle broken in 1.4 #1114

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment