New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add support for pip freeze to use multiple --requirement files #3703

Merged
merged 1 commit into from May 26, 2016

Conversation

Projects
None yet
2 participants
@eukaryote
Contributor

eukaryote commented May 20, 2016

  • updated freeze command to accept multiple --requirement
  • added test that uses multiple --requirement params and refactored
    existing test to reuse the boilerplate requirements options
  • modified warning and info message to include which requirement
    file a message is for now that there can be multiple
  • see issue #3599 for motivation

This is a resubmission based on master of pull request #3600 (based on develop), originally submitted on April 03, 2016. See ticket #3599 for discussion and an example.

pip freeze supports multiple --requirement files
- updated freeze command to accept multiple --requirement
- added test that uses multiple --requirement params and refactored
  existing test to reuse the boilerplate requirements options
- modified warning and info message to include which requirement
  file a message is for now that there can be multiple
- see issue #3599 for motivation
- resubmitting using new feature branch based on master, obsoleting
  pull request 3600 that was based on develop

@dstufft dstufft merged commit 46b6822 into pypa:master May 26, 2016

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details

waisbrot pushed a commit to waisbrot/pip that referenced this pull request Jul 5, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment