New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Switch default upgrade strategy to only-if-needed #4500

Merged
merged 2 commits into from May 19, 2017

Conversation

Projects
None yet
2 participants
@pradyunsg
Member

pradyunsg commented May 19, 2017

The final step of #3972.

pradyunsg added some commits May 19, 2017

@dstufft dstufft merged commit 410549d into pypa:master May 19, 2017

3 checks passed

continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
news-file/pr News files updated and/or change is trivial.
Details

@pradyunsg pradyunsg deleted the pradyunsg:switch-default-strategy branch Jun 13, 2017

@pradyunsg pradyunsg added this to the 10.0 milestone Oct 2, 2017

pv added a commit to pv/scipy-work that referenced this pull request Sep 27, 2018

MAINT: always specify install_requires in setup.py
The --upgrade behavior of pip was changed
(pypa/pip#4500), so we can always specify the
numpy dependency correctly.

Don't use setup_requires any more --- that's superseded by
pyproject.toml (and probably never worked properly).
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment