--user installs work properly with --upgrade #705

Merged
merged 1 commit into from Oct 18, 2012

Conversation

Projects
None yet
2 participants
Contributor

qwcode commented Oct 18, 2012

this in in response to pull #704.
this fixes the same problem, but also provides a test.
#704 fixes the issue via the "_permitted" check during uninstallation.

This pull is more direct, in that it doesn't allow the global install to be a conflict in the first place, which it shouldn't be during any --user install.

qwcode added a commit that referenced this pull request Oct 18, 2012

Merge pull request #705 from qwcode/user_upgrade
--user installs work properly with --upgrade

@qwcode qwcode merged commit 74a4e65 into pypa:develop Oct 18, 2012

1 check failed

default The Travis build failed
Details

kynan commented Dec 12, 2012

Does this patch also fix #354?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment