Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix keyerror in keep_outdated when using VCS dependencies #3768

Merged
merged 4 commits into from May 27, 2019

Conversation

@techalchemy
Copy link
Member

commented May 27, 2019

When pinning outdated dependencies, --keep-outdated can throw a KeyError on VCS dependencies because they don't have a version number to pin or compare.

Fix keyerror in keep_outdated when using VCS dependencies
Signed-off-by: Dan Ryan <dan@danryan.co>
techalchemy added 3 commits May 27, 2019
Add news entry
Signed-off-by: Dan Ryan <dan@danryan.co>
Update requirementslib to fix recursion error
Signed-off-by: Dan Ryan <dan@danryan.co>

@techalchemy techalchemy merged commit e627d9c into master May 27, 2019

@techalchemy techalchemy deleted the bugfix/keep-outdated-keyerror branch Jun 17, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.