Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

38.2.0 Breaks installs of several packages on 2.7 with UnicodeEncodeError parsing package METADATA #1212

Closed
mgrdcm opened this issue Nov 26, 2017 · 9 comments

Comments

@mgrdcm
Copy link

@mgrdcm mgrdcm commented Nov 26, 2017

Using setuptools==38.2.0 on Python 2.7.14, this setup.py will fail on any of the packages under install_requires with errors such as UnicodeEncodeError: 'ascii' codec can't encode character u'\u2013' in position 4258: ordinal not in range(128). None of these happened under 38.1.0 for instance. Error is happening on this line:

return email.parser.Parser().parsestr(value)

from setuptools import setup, find_packages

setup(
    name="test-setuptools-encoding-problem",
    version="1.0.0",
    packages=find_packages(),
    install_requires=[
        "requests==2.18.4",
        "eventbrite==3.3.3",
        "django_mathfilters==0.4.0",
        "django-countries==5.0",
    ]
)

Verified it doesn't happen with Python 3.6.3 for instance.

@mgrdcm mgrdcm changed the title 38.2.0 Breaks installs of several packages on 2.7 38.2.0 Breaks installs of several packages on 2.7 with UnicodeEncodeError in package METADATA Nov 26, 2017
@mgrdcm mgrdcm changed the title 38.2.0 Breaks installs of several packages on 2.7 with UnicodeEncodeError in package METADATA 38.2.0 Breaks installs of several packages on 2.7 with UnicodeEncodeError parsing package METADATA Nov 26, 2017
@benoit-pierre
Copy link
Member

@benoit-pierre benoit-pierre commented Nov 26, 2017

Thanks for the report, expect a bug fix release soon.

@mgrdcm
Copy link
Author

@mgrdcm mgrdcm commented Nov 26, 2017

Thanks @benoit-pierre! Let me know if I can help, for instance with testing.

@benoit-pierre
Copy link
Member

@benoit-pierre benoit-pierre commented Nov 26, 2017

@mgrdcm
Copy link
Author

@mgrdcm mgrdcm commented Nov 26, 2017

@benoit-pierre Works great for me!

@thijstriemstra
Copy link
Contributor

@thijstriemstra thijstriemstra commented Nov 26, 2017

@benoit-pierre not sure if this is the right place but 38.2.0 also broke this:

install_requires = [
    'luma.core>=1.1.1',
    'rpi_ws281x;platform_machine=="armv7l" and platform_system=="Linux"',
    'ws2812;platform_machine=="armv7l" and platform_system=="Linux"'
]

Packages are always installed (not only for ARM) and not skipped.

@benoit-pierre
Copy link
Member

@benoit-pierre benoit-pierre commented Nov 26, 2017

OK, fix for original issue released in 36.2.1.

@mgrdcm
Copy link
Author

@mgrdcm mgrdcm commented Nov 26, 2017

Thank you so much for the quick work @benoit-pierre!

@benoit-pierre
Copy link
Member

@benoit-pierre benoit-pierre commented Nov 26, 2017

@thijstriemstra: can you open a new issue with more info please?

@thijstriemstra
Copy link
Contributor

@thijstriemstra thijstriemstra commented Nov 26, 2017

@benoit-pierre will do, opened #1213

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants