New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

upload_docs fails with "Form data is not correctly encoded in UTF-8" #124

Closed
bb-migration opened this Issue Dec 15, 2013 · 2 comments

Comments

Projects
None yet
1 participant
@bb-migration

bb-migration commented Dec 15, 2013

Originally reported by: chrisw (Bitbucket: chrisw, GitHub: chrisw)


I'm attempting to upload docs for a new release of my package to pythonhosted.org but I get:

$ bin/docpy setup.py upload_docs --upload-dir=docs/_build/html
running upload_docs
Submitting documentation to http://pypi.python.org/pypi
Upload failed (400): Form data is not correctly encoded in UTF-8

My docs are all ascii as far as I know.

I'm using setuptools 2.0 on Python 2.7.3.

Downgrading to setuptools 1.4.2 fixed the problem.


@bb-migration

This comment has been minimized.

bb-migration commented Dec 16, 2013

Original comment by jaraco (Bitbucket: jaraco, GitHub: jaraco):


Correct regression in upload_docs in syntax adjustment. Fixes #124.

@bb-migration

This comment has been minimized.

bb-migration commented Dec 16, 2013

Original comment by jaraco (Bitbucket: jaraco, GitHub: jaraco):


Fix released in 2.0.1.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment