Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

fix PEP 518 configuration #1404

Merged
merged 1 commit into from Jun 29, 2018
Merged

Conversation

benoit-pierre
Copy link
Member

@benoit-pierre benoit-pierre commented Jun 28, 2018

Summary of changes

Add build-system.requires key to pyproject.toml:

Pull Request Checklist

  • News fragment added in changelog.d. See documentation for details

Add `build-system.requires` key to `pyproject.toml`:
- this is necessary with pip 10.0.1, as otherwise the defaults will be
  to require both `setuptools` and `wheel` (and we only need the later)
- a `pyproject.toml` with no `build-system.requires` key will be invalid
  and rejected by a future version of pip
  (see pypa/pip#5416 (comment))
@pganssle
Copy link
Member

LGTM.

@pganssle pganssle merged commit a94ccbf into pypa:master Jun 29, 2018
@benoit-pierre benoit-pierre deleted the fix_pyproject.toml branch September 14, 2018 16:19
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

2 participants