Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

drop support for Python 3.4 #1908

Merged
merged 1 commit into from Jan 1, 2020
Merged

Conversation

benoit-pierre
Copy link
Member

@benoit-pierre benoit-pierre commented Nov 15, 2019

Summary of changes

Drop support for Python 3.4, which reached end-of-life in March 2019.

Pull Request Checklist

  • News fragment added in changelog.d. See documentation for details

@benoit-pierre
Copy link
Member Author

@benoit-pierre benoit-pierre commented Nov 15, 2019

We might want to hold off merging this until a version with #1830 is released, so people stuck with Python 3.4 have a version of setuptools with support for python_requires when handling setup_requires/tests_require.

@JGoutin
Copy link
Contributor

@JGoutin JGoutin commented Nov 19, 2019

These files also seem to be deleted:

setuptools/py31compat.py
setuptools/py33compat.py
setuptools/py34compat.py

@benoit-pierre
Copy link
Member Author

@benoit-pierre benoit-pierre commented Nov 20, 2019

These files also seem to be deleted:

setuptools/py31compat.py
setuptools/py33compat.py
setuptools/py34compat.py

Those are still needed for Python 2.7.

@jaraco jaraco closed this Dec 31, 2019
@jaraco jaraco reopened this Dec 31, 2019
@jaraco jaraco closed this Jan 1, 2020
@jaraco jaraco reopened this Jan 1, 2020
@jaraco jaraco merged commit 95accbb into pypa:master Jan 1, 2020
4 of 6 checks passed
@benoit-pierre benoit-pierre deleted the drop_py34_support branch Jan 1, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

3 participants