Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Use importlib instead of imp in __bootstrap__ functions #2071

Merged
merged 1 commit into from Jun 22, 2020
Merged

Use importlib instead of imp in __bootstrap__ functions #2071

merged 1 commit into from Jun 22, 2020

Conversation

alexhenrie
Copy link
Contributor

@alexhenrie alexhenrie commented Apr 15, 2020

When the PYTHONWARNINGS environment variable is set, I often see the message DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses in conjuction with bootstrap files for compiled modules. This pull request fixes the code that triggers that warning.

Copy link
Member

@jaraco jaraco left a comment

Can you add a changelog entry please?

@alexhenrie
Copy link
Contributor Author

alexhenrie commented Jun 21, 2020

@jaraco Changelog entry added.

jaraco
jaraco approved these changes Jun 22, 2020
@jaraco jaraco merged commit 2a55538 into pypa:master Jun 22, 2020
26 checks passed
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

2 participants