Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Improve error message for unsupported metadata #755

Merged
merged 2 commits into from May 29, 2021

Conversation

@bhrutledge
Copy link
Contributor

@bhrutledge bhrutledge commented May 18, 2021

Related to #753, hopefully to give a little more clarity about the underlying issue. Feedback welcome on the wording.

@bhrutledge bhrutledge requested a review from di May 18, 2021
@bhrutledge bhrutledge force-pushed the 753-metadata-error branch from e5abeac to 5fc0e5a May 18, 2021
@bhrutledge
Copy link
Contributor Author

@bhrutledge bhrutledge commented May 26, 2021

@di Any thoughts on this?

Loading

di
di approved these changes May 26, 2021
Copy link
Member

@di di left a comment

I think it'd be more helpful if pkginfo was able to tell us what version it thought was invalid, but that doesn't seem possible so this is probably the best we can do.

Loading

@bhrutledge bhrutledge force-pushed the 753-metadata-error branch from 82453d7 to d1cdb16 May 29, 2021
@bhrutledge bhrutledge merged commit 7acd94e into pypa:master May 29, 2021
23 checks passed
Loading
@bhrutledge bhrutledge deleted the 753-metadata-error branch May 29, 2021
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

2 participants