Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Merge branch 'release/1.8' into develop

  • Loading branch information...
commit 5b904f88583d40954701c5471527fc07c7ae9056 2 parents a6d6ed7 + 119e624
@jezdez jezdez authored
Showing with 21 additions and 3 deletions.
  1. +20 −2 docs/news.txt
  2. +1 −1  virtualenv.py
View
22 docs/news.txt
@@ -15,8 +15,11 @@ Changes & News
with the upgraded Python.
-master (unreleased)
-~~~~~~~~~~~~~~~~~~~
+1.8 (2012-09-01)
+~~~~~~~~~~~~~~~~
+
+* **Dropped support for Python 2.4** The minimum supported Python version is
+ now Python 2.5.
* Fix `--relocatable` on systems that use lib64. Fixes #78. Thanks Branden
Rolston.
@@ -27,6 +30,21 @@ master (unreleased)
* Fix ``--relocatable`` when a script uses ``__future__`` imports. Thanks
Branden Rolston.
+* Fix a bug in the config option parser that prevented setting negative
+ options with environemnt variables. Thanks Ralf Schmitt.
+
+* Allow setting ``--no-site-packages`` from the config file.
+
+* Use ``/usr/bin/multiarch-platform`` if available to figure out the include
+ directory. Thanks for the patch, Mika Laitio.
+
+* Fix ``install_name_tool`` replacement to work on Python 3.X.
+
+* Handle paths of users' site-packages on Mac OS X correctly when changing
+ the prefix.
+
+* Updated the embedded version of distribute to 0.6.28 and pip to 1.2.
+
1.7.2 (2012-06-22)
~~~~~~~~~~~~~~~~~~
View
2  virtualenv.py
@@ -4,7 +4,7 @@
# If you change the version here, change it in setup.py
# and docs/conf.py as well.
-__version__ = "1.7.2" # following best practices
+__version__ = "1.8" # following best practices
virtualenv_version = __version__ # legacy, again
import base64
Please sign in to comment.
Something went wrong with that request. Please try again.