New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

2.2.3 ob_end_clean() issue #2964

Closed
gavinworks opened this Issue Sep 6, 2013 · 8 comments

Comments

Projects
None yet
7 participants
@gavinworks

gavinworks commented Sep 6, 2013

When the buffer is empty, errors are thrown in a couple of places (pages and navigation controllers). Fixed as per this forum thread by checking if the buffer has stuff to get rid of first: https://forum.pyrocms.com/discussion/24730/message-ob_end_clean-failed-to-delete-buffer-no-buffer-to-delete

@diegopego86

This comment has been minimized.

Show comment
Hide comment
@diegopego86

diegopego86 Sep 11, 2013

I have the same issue, on Navigation

diegopego86 commented Sep 11, 2013

I have the same issue, on Navigation

@philsturgeon

This comment has been minimized.

Show comment
Hide comment
@philsturgeon

philsturgeon Sep 15, 2013

Member

This was fixed for navigation in a PR, but not merged yet.

Member

philsturgeon commented Sep 15, 2013

This was fixed for navigation in a PR, but not merged yet.

@gavinworks

This comment has been minimized.

Show comment
Hide comment
@gavinworks

gavinworks Sep 15, 2013

Thanks 👍

gavinworks commented Sep 15, 2013

Thanks 👍

philsturgeon pushed a commit that referenced this issue Sep 19, 2013

@ChristianGiupponi

This comment has been minimized.

Show comment
Hide comment
@ChristianGiupponi

ChristianGiupponi Sep 20, 2013

Member

Can this be closed?

Member

ChristianGiupponi commented Sep 20, 2013

Can this be closed?

@robbiek

This comment has been minimized.

Show comment
Hide comment
@robbiek

robbiek Jun 5, 2014

I have just experienced this issue when attempting to create a new page.

Message: ob_end_clean(): failed to delete buffer. No buffer to delete

Filename: controllers/admin.php

Line Number: 103

version : 2.2.4

robbiek commented Jun 5, 2014

I have just experienced this issue when attempting to create a new page.

Message: ob_end_clean(): failed to delete buffer. No buffer to delete

Filename: controllers/admin.php

Line Number: 103

version : 2.2.4

@RyanThompson

This comment has been minimized.

Show comment
Hide comment
@RyanThompson

RyanThompson Jun 5, 2014

Member

I will take a peek see at this one for ya. Thanks for pointing it out!

Ryan Thompson
President / CEO
AI Web Systems, Inc.
www.aiwebsystems.com

t (877) 705-0806
m (309) 752-8581

On Jun 5, 2014, at 12:56 PM, Robbie Kleman notifications@github.com wrote:

I have just experienced this issue when attempting to create a new page.

Message: ob_end_clean(): failed to delete buffer. No buffer to delete

Filename: controllers/admin.php

Line Number: 103

version : 2.2.4


Reply to this email directly or view it on GitHub.

Member

RyanThompson commented Jun 5, 2014

I will take a peek see at this one for ya. Thanks for pointing it out!

Ryan Thompson
President / CEO
AI Web Systems, Inc.
www.aiwebsystems.com

t (877) 705-0806
m (309) 752-8581

On Jun 5, 2014, at 12:56 PM, Robbie Kleman notifications@github.com wrote:

I have just experienced this issue when attempting to create a new page.

Message: ob_end_clean(): failed to delete buffer. No buffer to delete

Filename: controllers/admin.php

Line Number: 103

version : 2.2.4


Reply to this email directly or view it on GitHub.

@robbiek

This comment has been minimized.

Show comment
Hide comment
@robbiek

robbiek Jun 6, 2014

I tried to replicate the issue on a clean install and it appears the error message only appears when i'm trying to create a new page after i have created a custom page type.

so i have created a custom page type and now when i go to create a page i get a popup where i can select a type but the above error message accompanies it. I't doesn't appear to have caused any issues at the moment as i can still carry on creating a new page.

robbiek commented Jun 6, 2014

I tried to replicate the issue on a clean install and it appears the error message only appears when i'm trying to create a new page after i have created a custom page type.

so i have created a custom page type and now when i go to create a page i get a popup where i can select a type but the above error message accompanies it. I't doesn't appear to have caused any issues at the moment as i can still carry on creating a new page.

@james182

This comment has been minimized.

Show comment
Hide comment
@james182

james182 Aug 8, 2014

To fix the error go to line #103 of System > CMS > modules > pages > controllers > admin.php
And replace ob_end_clean(); with if (ob_get_length()) ob_end_clean();

james182 commented Aug 8, 2014

To fix the error go to line #103 of System > CMS > modules > pages > controllers > admin.php
And replace ob_end_clean(); with if (ob_get_length()) ob_end_clean();

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment