Skip to content
Permalink
Browse files

Drop Python 3.4 support (EOL). Bump minimum requirement to Python 3.5.3

Closes #302
  • Loading branch information...
delivrance committed Aug 15, 2019
1 parent b42c658 commit dc74c441ccb026d5a5b2a3846dab81ebdbd0d729
@@ -56,7 +56,7 @@ ground up in Python and C. It enables you to easily create custom apps for both

### Requirements

- Python 3.4 or higher.
- Python 3.5.3 or higher.
- A [Telegram API key](https://docs.pyrogram.org/intro/setup#api-keys).

### Installing
@@ -9,7 +9,7 @@ We recommend using the latest versions of both Python 3 and pip.

.. important::

Pyrogram supports **Python 3** only, starting from version 3.4. **PyPy** is supported too.
Pyrogram supports **Python 3** only, starting from version 3.5.3. **PyPy** is supported too.

Install Pyrogram
----------------
@@ -16,19 +16,10 @@
# You should have received a copy of the GNU Lesser General Public License
# along with Pyrogram. If not, see <http://www.gnu.org/licenses/>.

import sys

if sys.version_info[:3] in [(3, 5, 0), (3, 5, 1), (3, 5, 2)]:
from .vendor import typing

# Monkey patch the standard "typing" module because Python versions from 3.5.0 to 3.5.2 have a broken one.
sys.modules["typing"] = typing

__version__ = "0.16.0.dev"
__license__ = "GNU Lesser General Public License v3 or later (LGPLv3+)"
__copyright__ = "Copyright (C) 2017-2019 Dan <https://github.com/delivrance>"

from .errors import RPCError
from .client import *
from .client.handlers import *
from .client.types import *

This file was deleted.

This file was deleted.

0 comments on commit dc74c44

Please sign in to comment.
You can’t perform that action at this time.