New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

pysam requires cython 0.20.2 is used with python 3.4.x #37

Closed
StuntsPT opened this Issue Sep 8, 2014 · 4 comments

Comments

Projects
None yet
2 participants
@StuntsPT
Contributor

StuntsPT commented Sep 8, 2014

The title says it all.
This is due to some late changes in the python 3.4 development cycle, that caused a problem with cython (Yay! Dependency hell).
The only thing pysam can do though, is to stated it in the documentation... I am not really sure where, though... But it should save quite a few headaches, because this took me a while to figure out.

@AndreasHeger

This comment has been minimized.

Contributor

AndreasHeger commented Sep 9, 2014

Thanks. You are right, I don't want to force a cython upgrade on everyone, but I will see if I can check for the cython and python version and produce an error message in setup.py.

@StuntsPT

This comment has been minimized.

Contributor

StuntsPT commented Sep 9, 2014

That should suffice, I guess.
Also, keep in mind that if you would "force" a cython upgrade, you would also be forcing an upgrade to python itself (any cython above 0.18 requires at least python 3.2).
See what I meant about dependency hell? =-)

@AndreasHeger

This comment has been minimized.

Contributor

AndreasHeger commented Nov 11, 2014

Hi @StuntsPT , I tried implementing a check in setup.py but had second thoughts - it ended up being quite a few lines of code for a simple version check. I have added a section to the FAQ instead.

Best wishes,
Anderas

@StuntsPT

This comment has been minimized.

Contributor

StuntsPT commented Nov 11, 2014

I suppose that should be more than enough.
People are supposed to read the docs anyway. And they likely will in case of trouble. =-)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment