Fix image loading when rotating by 0 deg #2052

Merged
merged 1 commit into from Aug 5, 2016

Projects

None yet

3 participants

@homm
Member
homm commented Aug 5, 2016

This fixes image rotation in cases when angle % 360.0 == 0 and image is not loaded yet.

@homm homm fix image loading when rotating by 0 deg
3185262
@homm
Member
homm commented Aug 5, 2016

@wiredfool from my point of view, this is critical issue worth 3.3.1, but this is fully up to you.

@homm homm merged commit bc2c933 into python-pillow:master Aug 5, 2016

3 checks passed

continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
coverage/coveralls Coverage increased (+0.01%) to 78.112%
Details
@homm homm deleted the uploadcare:rotate-loading branch Aug 5, 2016
@wiredfool wiredfool added this to the 3.3.1 milestone Aug 6, 2016
@tisdall
tisdall commented Aug 12, 2016

I did an upgrade and just got stung by this...

@homm
Member
homm commented Aug 15, 2016 edited

@tisdall You can fix it on your side by explicit im.load() before the rotating.

@tisdall
tisdall commented Aug 15, 2016

I actually changed it to test for angle % 360.0 == 0 before calling rotate. I just wanted to point out there was at least one person affected by this issue to hopefully add weight to the 3.3.1 suggestion. Also, I was very lucky to notice this issue mentioned in the change log as the traceback is very cryptic and I likely would have spent a long time trying to sort out the real issue.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment