fix UTF16 BOM removal problem on ruby 1.9.2 #7

Merged
merged 1 commit into from Jul 16, 2013

Projects

None yet

7 participants

@trampoline

hi ping,

here's a fix for the problem with the BOM removal regexp on ruby 1.9.2

it's tested on both

ruby-1.9.2-p180 [ x86_64 ]
ruby-1.8.7-p334 [ x86_64 ]

against an Exchange 2010 SP1 server with NTLM authentication

it seems there are further problems with the ntlm_http.rb on ruby 1.9.2, but i authenticated fine using latest httpclient and 'net/ntlm' portion of pyu-ntlm-http gem, so i will raise another bug for the other problems

@lxcid
lxcid commented Jul 15, 2011

This fix my problem. Thanks.

@ramonpin
ramonpin commented Nov 2, 2011

Same problem under Linux. This could be a good merge. Thx.

@lxcid
lxcid commented Nov 2, 2011

I had fork the repo @ http://github.com/lxcid/ntlm-http that is bundler friendly.

Just have the following line in your Gemfile

gem "pyu-ntlm-http", :git => "git://github.com/lxcid/ntlm-http.git", :branch =>"1.9_utf16_bom_fix"
@ramonpin
ramonpin commented Nov 2, 2011

Thx Stan... really a great work with this gem.

El 02/11/2011 14:43, Stan Chang Khin Boon escribió:

I had fork a branch @ http://github.com/lxcid/ntlm-http that is bundler friendly.

Just have the following line on your Gemfile

 gem "pyu-ntlm-http", :git =>  "git://github.com/lxcid/ntlm-http.git", :branch =>"1.9_utf16_bom_fix"
@unimatrixZxero

Stan's fix worked fine for me too. THX

@mmmries
mmmries commented Nov 12, 2012

This fix worked for me on jruby-1.7.0 and mri-1.9.3-p286. I'm pointing to the fork mentioned above until this gets merged and released to the gem.

@pyu10055 pyu10055 merged commit ef41474 into pyu10055:master Jul 16, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment