Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

obsolete widget constructor #250

Closed
ursribi opened this Issue Sep 8, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@ursribi
Copy link

ursribi commented Sep 8, 2015

/* qTranslate-X Widget */

class qTranslateXWidget extends WP_Widget {

// obsolete constructor in version wp 4.3.
// function qTranslateXWidget() {

// use this function in version wp 4.3
function __construct() {
$widget_ops = array('classname' => 'qtranxs_widget', 'description' => __('Allows your visitors to choose a Language.', 'qtranslate') );
// obsolete constructor call in version wp 4.3.
// $this->WP_Widget('qtranslate', __('qTranslate Language Chooser', 'qtranslate'), $widget_ops);

// use this call in version wp 4.3
parent::__construct('qtranslate', __('qTranslate Language Chooser', 'qtranslate'), $widget_ops);
}

@johnclause johnclause added the bug label Sep 9, 2015

@johnclause

This comment has been minimized.

Copy link
Member

johnclause commented Sep 9, 2015

Fixed in new soon to be released version 3.4.5, available from GitHub: https://github.com/qTranslate-Team/qtranslate-x - thanks a lot for the report!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.