Skip to content
Permalink
Browse files

Raise minimum support to Windows 7

  • Loading branch information...
Chocobo1 committed Aug 4, 2019
1 parent c0fc4e6 commit 2f0ae7a7d8c53d8c1d1bee08d61e5dcb28cfd61b
Showing with 8 additions and 10 deletions.
  1. +5 −4 cmake/Modules/winconf.cmake
  2. +0 −6 conf.pri.windows
  3. +3 −0 winconf.pri
@@ -19,14 +19,15 @@ set(LibtorrentRasterbar_CUSTOM_BOOST_DEPENDENCIES system)
#set(Boost_USE_STATIC_LIBS True)
#set(Boost_USE_STATIC_RUNTIME True)

add_definitions(-DUNICODE
add_definitions(
-DNTDDI_VERSION=0x06010000
-D_WIN32_WINNT=0x0601
-D_WIN32_IE=0x0601
-DUNICODE
-D_UNICODE
-DWIN32
-D_WIN32
-DWIN32_LEAN_AND_MEAN
-DNTDDI_VERSION=0x05010000
-D_WIN32_WINNT=0x0501
-D_WIN32_IE=0x0501
-D_CRT_SECURE_NO_DEPRECATE
-D_SCL_SECURE_NO_DEPRECATE
-DNOMINMAX
@@ -35,17 +35,11 @@ LIBS += zlib.lib
#LIBS += libcrypto libssl
#LIBS += libz

DEFINES += NTDDI_VERSION=0x05010000
DEFINES += _WIN32_WINNT=0x0501
DEFINES += _WIN32_IE=0x0501

# Disable to use Boost auto-linking
DEFINES += BOOST_ALL_NO_LIB
# Use one of the following options
DEFINES += BOOST_SYSTEM_STATIC_LINK
#DEFINES += BOOST_SYSTEM_DYN_LINK
# Boost 1.60+ defaults to Vista+ support. The define below enables XP support again.
DEFINES += BOOST_USE_WINAPI_VERSION=0x0501
# Enable if encountered build error with boost version <= 1.59
#DEFINES += BOOST_NO_CXX11_RVALUE_REFERENCES

@@ -6,6 +6,9 @@ DEFINES += BOOST_EXCEPTION_DISABLE
DEFINES += TORRENT_USE_OPENSSL
DEFINES += TORRENT_DISABLE_RESOLVE_COUNTRIES

DEFINES += NTDDI_VERSION=0x06010000
DEFINES += _WIN32_WINNT=0x0601
DEFINES += _WIN32_IE=0x0601
DEFINES += UNICODE
DEFINES += _UNICODE
DEFINES += WIN32

0 comments on commit 2f0ae7a

Please sign in to comment.
You can’t perform that action at this time.