New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

configure issues #10142

Open
dsm1212 opened this Issue Jan 9, 2019 · 0 comments

Comments

Projects
None yet
2 participants
@dsm1212
Copy link

dsm1212 commented Jan 9, 2019

I'm trying to build qbittorrent for my nas os. Debian 7 and compiler is gcc 4.9. I last built a 4.2.0alpha successfully a few months back. This time I ran into two issues with configure. Hopefully this is pilot error of some kind.

My command is:
./configure --prefix=/usr --with-boost=/usr/local --disable-gui --enable-webui
I found I have to add the last argument in this version.

Problem one:
configure checks for __cplusplus equal to 201402L, but in 4.9 c++14 defines as 201300L. I'm not sure if this is a mistake or if there is something in the 5.x compiler you really need. c++14 in 4.9 should be relatively ok so I edited configure for now to change the version number. If I can get to compiling I'll probably find out if this was a mistake or not.

Problem two:
qmake is complaining about translation files .tm missing. My sources only have .ts files. I think lrelease should have run to generate those but it wasn't. I'm not very familiar with qmake. Maybe because of my combination of disable-gui and enable-webui this happened? in src.pro I see it defaults to using lrelease-qt5 but my lrelease for qt5 is just called lrelease so I tried setting QMAKE_LRELEASE to the full path to my qt5 lrelease but it did not help.

Any help? thanks

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment