Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

99.9% file after force recheck. Usually happens after moving file to a new drive #10380

Open
tehmasterer opened this Issue Mar 13, 2019 · 4 comments

Comments

Projects
None yet
4 participants
@tehmasterer
Copy link

tehmasterer commented Mar 13, 2019

Please provide the following information

qBittorrent version and Operating System

4.15 on Windows 10

What is the problem

I often move files from one drive to another and want to continue seeding. When I move the file, I set the new location and force recheck. Some of my torrents show as 99.9% after doing a force recheck. It usually happens with a torrent where I have selected only specific files to download. For example I'll download the primary file, say a movie, download the subtitle, ignore the .NFO. Well the movie is 99.9% complete, the subtitle is 100%, and the .NFO is Not downloaded as normal. Before moving this torrent it was 100% for both files and seeding as normal.

What is the expected behavior

Files should be 100% after moving and force recheck as it was previously.

Steps to reproduce

  • Move file from one hard drive to another MANUALLY (not using qbittorrent's move feature!)
  • Set location of the file
  • Force recheck

Extra info(if any)

(type here)

@Supralateral

This comment has been minimized.

Copy link

Supralateral commented Mar 14, 2019

You're probably not moving the hidden folder/files

I'm curious, why on earth are you moving the files manually? It rather seems like you're doubling the work for yourself. The client is plenty capable of moving files and folders on its own

@thalieht

This comment has been minimized.

Copy link
Contributor

thalieht commented Mar 14, 2019

I had this a few times but i didn't notice a pattern. I didn't move anything manually (don't remember if the affected torrents were moved at all).

@tehmasterer

This comment has been minimized.

Copy link
Author

tehmasterer commented Mar 14, 2019

@Supralateral Yes you are right. There were 3 hidden .parts files in my movies directory.

As for your question... Prior to I think... version 4.04? using set location to move torrent contents did not work properly. It either did not move the contents correctly, overwrote certain files, or deleted them all together. I remember this was a big issue and there was a bug post about it. Frankly, I still don't trust that method and would rather do it manually.

@airium

This comment has been minimized.

Copy link
Contributor

airium commented Mar 14, 2019

A piece can span over multiple files. To verify the file you want, qbt has to download the whole piece and leave the part you don't want as hidden part files. It seems qbt doesn't move these incomplete files, so at the new location it will fail to verify edge pieces, giving 99%+ progress.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.