Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

4.1.6 not working on my Windows 10 #10581

Open
rhobotjones opened this issue May 6, 2019 · 97 comments

Comments

Projects
None yet
@rhobotjones
Copy link

commented May 6, 2019

Please provide the following information

qBittorrent version and Operating System

4.1.6 Windows 10

If on linux, libtorrent and Qt version

(type here)

What is the problem

After installing qBittorrent will not startup

What is the expected behavior

qBittorrent will start and run

Steps to reproduce

successfully install 4.1.6

Extra info(if any)

(type here)

@LAUVz

This comment has been minimized.

Copy link

commented May 6, 2019

Same here it just instantly goes in not responding and then just closes.

@LittleVulpix

This comment has been minimized.

Copy link

commented May 6, 2019

Yeah it's broken.

@NetworkPro

This comment has been minimized.

Copy link

commented May 6, 2019

Same here x64
w10 1809 latest patch level

@thalieht

This comment has been minimized.

Copy link
Contributor

commented May 6, 2019

Maybe unimportant but which win 10 version? I'm still on 1803, no problems with starting 4.1.6.

@rhobotjones

This comment has been minimized.

Copy link
Author

commented May 6, 2019

1903

@LittleVulpix

This comment has been minimized.

Copy link

commented May 6, 2019

1703

@Neocridas

This comment has been minimized.

Copy link

commented May 6, 2019

Same here with me (1903)
Workaround:
run qbittorent in administrator and it works.

@malinwa001

This comment has been minimized.

Copy link

commented May 6, 2019

Same here, work around did't work.

32 bit versions is working well.

@LittleVulpix

This comment has been minimized.

Copy link

commented May 6, 2019

Mine already runs as admin, and well, it doesn't run. For the time being, back to 4.1.5 which works no problem.

@njscorpion

This comment has been minimized.

Copy link

commented May 6, 2019

I am using Win 10 Ent x64 build 1903.18362.86 after i updated to QBT 4.1.6 it was working for sometime but every time i had start it twice as the first time it was crashing. But now it opens for few seconds and then crashes.

@Chocobo1

This comment has been minimized.

Copy link
Member

commented May 6, 2019

I suspect it is the same as #9667 (comment)
So you'll need to edit C:\Users\<username>\AppData\Roaming\qBittorrent\qBittorrent.ini and change DownloadTrackerFavicon=true to DownloadTrackerFavicon=false save and restart qbt.

Note: You only need to edit the ini if you upgraded from older qbt version. If you did a clean install then no editing is required.

@MoralisRubric

This comment has been minimized.

Copy link

commented May 6, 2019

Having the same issue, with win 10 (1903) x64.

@Chocobo1 suggested solution does not working for me.

@Cologler

This comment has been minimized.

Copy link

commented May 6, 2019

@Chocobo1 suggested solution does not working for me too. fixes by back to 4.1.5 🙃

@TiagoJSilva

This comment has been minimized.

Copy link

commented May 6, 2019

I'm having the same issue in Windows 7 x64. qBT 4.1.6 starts loading, takes the usual long time to load all my torrents, then "Application not responding" without even painting the window. Went back to 4.1.5 although the fix for checking all files at the same time was very important for me.

@legithubuser

This comment has been minimized.

Copy link

commented May 6, 2019

It doesn't even want to install on my WIndows 10 64 bit system. I get a "can't write file.exe" error.

@phucyall

This comment has been minimized.

Copy link

commented May 6, 2019

I have 2 VMs running Windows 10 on it. Both are very similar configuration and same version of windows. Both just updated to 4.1.6 x64 and both had crashes right after startup. For one of them, the fix suggested by @Chocobo1 worked perfectly. For the other one, the fix or running as administrator has not worked. I'm downgrading now. The exception from Event Viewer does not provide any useful information:

Faulting module name: qbittorrent.exe, version: 4.1.6.0, time stamp: 0x5ccf3300
Exception code: 0xc0000005
Fault offset: 0x0000000000aa83e0
Faulting process id: 0x1500
Faulting application start time: 0x01d5040911ae259a
Faulting application path: C:\Program Files\qBittorrent\qbittorrent.exe
Faulting module path: C:\Program Files\qBittorrent\qbittorrent.exe
Report Id: 24aef07f-baa1-4f58-ac25-3d713e5f54e2
Faulting package full name: 
Faulting package-relative application ID: ```
@TiagoJSilva

This comment has been minimized.

Copy link

commented May 6, 2019

My issue was solved with the favicon fix in qbittorrent.ini

@sledgehammer999

This comment has been minimized.

Copy link
Contributor

commented May 6, 2019

Those still having crashes can you try the following build?
Just extract and run in any folder. (or you can overwrite the installed files)

Link: https://builds.shiki.hu/temp/qbittorrent_4.1.6_x64_for_issue_10581.7z

@LittleVulpix

This comment has been minimized.

Copy link

commented May 6, 2019

Is there source for this build / commits? One can never be too cautious running random stuff from the internet... Thanks!

@sledgehammer999

This comment has been minimized.

Copy link
Contributor

commented May 6, 2019

@LittleVulpix in case you didn't know I am the admin. I make the official builds and releases.
This particular build is the exact same source as 4.1.6, but with the /guard:cf compiler/linker option disabled. (I have run into issues in the past with it).
If this doesn't work, I'll have to try something else.

@LittleVulpix

This comment has been minimized.

Copy link

commented May 6, 2019

@sledgehammer999 I didn't; my bad. I tried it in my test system, but the problem is the same. It also takes a very long time to init as opposed to 4.1.5 which launches in a few seconds. 4.1.6 takes about 30 seconds and then it crashes.

@sledgehammer999

This comment has been minimized.

Copy link
Contributor

commented May 6, 2019

Can you try the following build? It is v4.1.5 but with all the new libs used in 4.1.6. I am trying to figure it if the problem is in the new qbt code or in the new libs.
Link: https://builds.shiki.hu/temp/qbittorrent_4.1.5_x64_for_issue_10581.7z

@LittleVulpix

This comment has been minimized.

Copy link

commented May 6, 2019

That one crashes as well. Though, it just "disappears silently". I don't get a windows "crash" message anymore. Nonetheless, it does not work.

@phucyall

This comment has been minimized.

Copy link

commented May 6, 2019

@sledgehammer999 both the files you attached are still causing crashes on my machine. Looking at the crash report there's nothing even remotely useful in there. If you have a debug build you want me to try I'll be more than happy to test it.

@sledgehammer999

This comment has been minimized.

Copy link
Contributor

commented May 6, 2019

Looking at the crash report

Wait! You get a window of qbt with a stacktrace? If yes, can you post it?

@LittleVulpix

This comment has been minimized.

Copy link

commented May 6, 2019

I think he means the windows "reliability" crash report, stuff like:

Problem signature
Problem Event Name: APPCRASH
Application Name: qbittorrent.exe
Application Version: 4.1.5.0
Application Timestamp: 5cd067b0
Fault Module Name: qbittorrent.exe
Fault Module Version: 4.1.5.0
Fault Module Timestamp: 5cd067b0
Exception Code: c0000005
Exception Offset: 0000000000aa8110
OS Version: 10.0.15063.2.0.0.256.48
Locale ID: 2057
Additional Information 1: 4b4d
Additional Information 2: 4b4d9c387d9719f8e22f494826099edf
Additional Information 3: 7bc7
Additional Information 4: 7bc7fc03d52134064a3b598b6489e1ca

Which, as he noted, tells you nothing.

@sledgehammer999

This comment has been minimized.

Copy link
Contributor

commented May 6, 2019

New build. It is v4.1.6 but with the libtorrent and boost version used in v4.1.5.
(that libtorrent version fails to build with latest boost)
Link: https://builds.shiki.hu/temp/qbittorrent_4.1.6_x64_for_issue_10581_v2.7z

@LittleVulpix

This comment has been minimized.

Copy link

commented May 6, 2019

This crashes as well.

@phucyall

This comment has been minimized.

Copy link

commented May 6, 2019

This crashes as well.

Same. And yes I meant the same crash report that @LittleVulpix posted.

@amaajemyfren

This comment has been minimized.

Copy link

commented May 10, 2019

I suspect it is the same as #9667 (comment)
So you'll need to edit C:\Users\<username>\AppData\Roaming\qBittorrent\qBittorrent.ini and change DownloadTrackerFavicon=true to DownloadTrackerFavicon=false save and restart qbt.
Note: You only need to edit the ini if you upgraded from older qbt version. If you did a clean install then no editing is required.

This worked well for me. Thanks for it.

After a few days of issues with this I would like to rescind this. I have had to revert to v4.1.5.

@LittleVulpix

This comment has been minimized.

Copy link

commented May 10, 2019

Personally, I'm using @sledgehammer999 's "v3" version from here:

https://builds.shiki.hu/temp/qbittorrent_4.1.6_x64_for_issue_10581_v3.7z

with no issues. None of the other solutions worked for me.

@Ryrynz

This comment has been minimized.

Copy link

commented May 10, 2019

After a few days of issues with this I would like to rescind this. I have had to revert to v4.1.5.

Did you even try build v3 as LittleVulpix quoted above me?

@amaajemyfren

This comment has been minimized.

Copy link

commented May 10, 2019

After a few days of issues with this I would like to rescind this. I have had to revert to v4.1.5.

Did you even try build v3 as LittleVulpix quoted above me?

No I did not - I had only used the config changes given. Was updating it in case someone was tracking how many issues were resolved by changing the config.

@IntelliMoo

This comment has been minimized.

Copy link

commented May 10, 2019

Went back to 4.1.5 as well, exiting the app was destroying the Reliability Monitor rating. lol

@JoshDaone

This comment has been minimized.

Copy link

commented May 11, 2019

Personally, I'm using @sledgehammer999 's "v3" version from here:

https://builds.shiki.hu/temp/qbittorrent_4.1.6_x64_for_issue_10581_v3.7z

with no issues. None of the other solutions worked for me.

This build also works for me since last time crash.

@Sleepovers

This comment has been minimized.

Copy link

commented May 12, 2019

Very weird indeed, I just installed the standard version of QBT 4.1.6 and it just worked....

@sledgehammer999

This comment has been minimized.

Copy link
Contributor

commented May 12, 2019

@IntelliMoo can you try the following build? v4.1.6, Qt5 5.12.3, openssl 1.0.2r
Link: https://builds.shiki.hu/temp/qbittorrent_4.1.6_x64_for_issue_10581_v4.7z

@IntelliMoo

This comment has been minimized.

Copy link

commented May 12, 2019

@zeilja

This comment has been minimized.

Copy link

commented May 13, 2019

Hope this helps: Visual studio 2017 attached to process
Seems networking-related in my case

@sledgehammer999

This comment has been minimized.

Copy link
Contributor

commented May 13, 2019

@zeilja which version did you use? The official 4.1.6 or one of my custom builds from this thread?

@zeilja

This comment has been minimized.

Copy link

commented May 13, 2019

the official one. I am trying to compile on windows but so far unsuccessful with visual studio or qt creator. Need to compile deps first.

I'm on win 8.1 pro x64

@sledgehammer999

This comment has been minimized.

Copy link
Contributor

commented May 13, 2019

@zeilja We know about the official one. We don't want more debugging.
The v3 custom build of mine, works fine, but some users have reported that it crashes during exit. It would be nice if you could catch that debugging info. This build uses a newer qt which is more compatible with opeenssl 1.1.x series.
The v4 build should work without any problems. It uses both the newer qt and older-stabler 1.0.x series of openssl. (like v4.1.5 did).
v3: #10581 (comment)
v4: #10581 (comment)

@gorvinsky

This comment has been minimized.

Copy link

commented May 14, 2019

Mine keep crashing when starting the app. Have to try multiple times until it can be opened normally. I have to do this every time I wish to open the app. Not sure if it's related but I got plenty of torrents running/seeding.

qBittorrent v4.1.6 (64-bit)
Edition: Windows 10 Pro
Version: 1803
OS Build: 17134.706

@buszmen201

This comment has been minimized.

Copy link

commented May 14, 2019

Mine was freezing when starting. 4.1.6v4 EXE's fixed the issue :)

Windows 10 Pro [1809, 17763.475]

@matrix934

This comment has been minimized.

Copy link

commented May 14, 2019

Mine keep crashing on exit.
Visual Studio Debugger says "Exception thrown at 0x00007FF7AD84DD91 in qbittorrent.exe: 0xC0000005: Access violation reading location 0x000002BCD8AFCA78."
It also ask me to find "qvector.h".

qBittorrent 4.1.6 v4
Windows 10 Home 1803 (64-bit)

@franciscofjs

This comment has been minimized.

Copy link

commented May 15, 2019

@IntelliMoo can you try the following build? v4.1.6, Qt5 5.12.3, openssl 1.0.2r
Link: https://builds.shiki.hu/temp/qbittorrent_4.1.6_x64_for_issue_10581_v4.7z

Thanks!
It worked here!

qBittorrent 4.1.6 v4
Windows 10 Pro 1809 (64-bit)
OS build 17763.475

@tarkilhk

This comment has been minimized.

Copy link

commented May 16, 2019

I can confirm that the v4 fixed the crashes for me (fresh install 4.1.6 originally).
It used to crash after few minutes, now it's been running for 12 hours+.
I'll update again in here in case another crash happen in the coming days

@NetworkPro

This comment has been minimized.

Copy link

commented May 16, 2019

yes works here too

@gorvinsky

This comment has been minimized.

Copy link

commented May 16, 2019

I suspect it is the same as #9667 (comment)
So you'll need to edit C:\Users\<username>\AppData\Roaming\qBittorrent\qBittorrent.ini and change DownloadTrackerFavicon=true to DownloadTrackerFavicon=false save and restart qbt.
Note: You only need to edit the ini if you upgraded from older qbt version. If you did a clean install then no editing is required.

This worked well for me. Thanks for it.

After a few days of issues with this I would like to rescind this. I have had to revert to v4.1.5.

This works for me for a 2-3 days now.

@IntelliMoo

This comment has been minimized.

Copy link

commented May 16, 2019

Unfortunately I now have bad news to report about the 4.1.6 v4 version, I've gotten the crashes on exit again a couple of times.

Exception Code: c0000005
Exception Offset: 00000000007f8630
(Dumps attached if helps: CrashDumps.zip)

Seems the longer the app is left running, the greater the chance. Going back to 4.1.5 again unless a new test comes up, thanks. :)

@ollemonster

This comment has been minimized.

Copy link

commented May 19, 2019

Is it possible that this program now gets blocked by antivirus software? I had no trouble earlier but today it would 4.1.5 would not start and when trying to update it said i could not write qbittorrent.exe. I could also not install deluge or bittorrent. When I tried unzipping your archive I was not allowed to extract the qbittorrent.exe out of the archive.

@IntelliMoo

This comment has been minimized.

Copy link

commented May 20, 2019

Is it possible that this program now gets blocked by antivirus software? I had no trouble earlier but today it would 4.1.5 would not start and when trying to update it said i could not write qbittorrent.exe. I could also not install deluge or bittorrent. When I tried unzipping your archive I was not allowed to extract the qbittorrent.exe out of the archive.

I would guess that is due to whatever antivirus software you have getting an update that wrongly "suggests" qBittorrent is bad. Have subsequent antivirus updates fixed the problem? If not, better report it as a false-positive to that antivirus vendor, and in the meantime you can add an exception for qBittorrent easy enough.

@christoferd

This comment has been minimized.

Copy link

commented May 21, 2019

Windows 10 Events Warnings keep appearing when qBittorrent v4.1.6 is running
Profile notification of event Unload for component {B31118B2-1F49-48E5-B6F5-BC21CAEC56FB} failed, error code is See Tracelogging for error details.
Profile notification of event Load for component {B31118B2-1F49-48E5-B6F5-BC21CAEC56FB} failed, error code is See Tracelogging for error details.

Solution:
Managed to get it running by opening it a couple of times as Administrator

@amaajemyfren

This comment has been minimized.

Copy link

commented May 21, 2019

After a few days of issues with this I would like to rescind this. I have had to revert to v4.1.5.

Did you even try build v3 as LittleVulpix quoted above me?

No I did not - I had only used the config changes given. Was updating it in case someone was tracking how many issues were resolved by changing the config.

I have been using this version since the day above and it works well for me.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.