Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

[Solved] qBittorrent not building in Ubuntu 13.10 #1124

Closed
Dnamb opened this Issue Nov 24, 2013 · 9 comments

Comments

Projects
None yet
2 participants

Dnamb commented Nov 24, 2013

I keep getting this following error, when I configure:

Configuring qbittorrent ...
Verifying Qt 4 build environment ... ok
Checking for Qt >= 4.6 ... yes
Checking for QtDBus >= 4.5 ... yes
Checking for pkg-config executable ... yes
Checking for libtorrent-rasterbar >= 0.16.0 ... yes
Checking for libboost ...Could not find boost system library!
no

Error: need libboost!

I installed the libboost-all-dev 1.53, but still getting the same error...
Even the official PPA have build errors for saucy (13.10)

Contributor

sledgehammer999 commented Nov 24, 2013

Is there any conf.log or similar file produced? If yes, can you pastebin the contents and link here?

Dnamb commented Nov 24, 2013

There isn't much in the conf.log file, I'll post it here itself
Below is the content of the conf.log file:


/usr/lib/x86_64-linux-gnu/qt4/bin/moc -DHAVE_MODULES -DQT_NO_DEBUG -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4 -I. conf4.cpp -o conf4.moc
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -DHAVE_MODULES -DQT_NO_DEBUG -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++-64 -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4 -I. -o conf4.o conf4.cpp
g++ -m64 -Wl,-O1 -o conf conf4.o -L/usr/lib/x86_64-linux-gnu -lQtCore -lpthread


So whats your take on this?

Contributor

sledgehammer999 commented Nov 24, 2013

Damn, my system can't Xubuntu on a VM fast enough(although it can run Windows XP fine...) and I don't want to install yet another OS on the disk. I already have Windows XP and Debian sid(xfce)....

If you are up to the task of getting your hands dirty and you know your way around linux here are 2 hints:

  1. The configure script is generated by the qconf utility ->http://delta.affinix.com/qconf/
  2. qconf uses the files inside the qcm folder, so you should take look at qcm/libboost.qcm
Contributor

sledgehammer999 commented Nov 25, 2013

I think I found the problem. Care to test it?

  1. Edit qcm/libboost.qcm

  2. Go to line 78 and find:

    libDirs << "/usr/lib/" << "/usr/lib64/" << "/usr/local/lib/" << "/usr/local/lib64/";

  3. Replace it with:

    libDirs << "/usr/lib/" << "/usr/lib64/" << "/usr/local/lib/" << "/usr/local/lib64/" << "/usr/lib/x86_64-linux-gnu/" << "/usr/lib/i386-linux-gnu/";

(one line)
4. Rebuild the configure script using qconf or alternatively find the same string inside the configure script and replace it.

Dnamb commented Nov 25, 2013

Changed the libboost.qcm file, still the error persists.

Dnamb commented Nov 25, 2013

I removed libboost-all-dev 1.53, and installed libboost-all-dev 1.54 and libboost-dev 1.54 and then edited the libboost.qcm and configure file for libDirs. Its a progress but I am getting a new error now:


Configuring qbittorrent ...
Verifying Qt 4 build environment ... ok
Checking for Qt >= 4.6 ... yes
Checking for QtDBus >= 4.5 ... yes
Checking for pkg-config executable ... yes
Checking for libtorrent-rasterbar >= 0.16.0 ... yes
Checking for libboost ... yes
Checking for GeoIP Database (optional) ... yes
Checking for qtsingleapplication library ... [shipped] yes
sh: 1: Syntax error: "(" unexpected


Error was my doing. FIXED see next comment.

Dnamb commented Nov 25, 2013

Error on my part, IT IS WORKING NOW! Comment #5 solved my problem along with installing the latest libboost version (-all-dev & -dev) 1.54, seems to do the trick.

Now, the official PPA builds will also work... 👍

@ghost

ghost commented Nov 26, 2013

The official PPA seems failed to build... :(

Dnamb commented Nov 26, 2013

@fuyin You can build it yourself, till the PPA error has been resolved.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment