Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

WebAPI can't produce 415 reponse #11323

Open
SonOfDiablo opened this issue Oct 3, 2019 · 0 comments

Comments

@SonOfDiablo
Copy link

commented Oct 3, 2019

Please provide the following information

qBittorrent version and Operating System

qBittorrent 4.1.8
OS: Windows 10

What is the problem

When dealing with the WebAPI I can't get a response of "415 Torrent file is not valid".
Whenever I try to add a torrent link via the WebAPI (/api/v2/torrents/add) I get a 200 response code and the body is "Ok.".
Even when giving a bad url in the WebUI I don't get any error messages and it just acts as if everything is fine.

What is the expected behavior

Expected behavior would be to get a 415 response code as the API documentations states.

Steps to reproduce

I'm using the following Python code to send the request

qbitUrl='http://127.0.0.1:8080/api/v2/torrents/add'
data={
		'urls':'http://www.somelink.to/file.torrent',
		'autoTMM':False,
		'savepath':'C:\\Downloads\\',
		'paused':False,
		'root_folder':True
	}
	response = requests.post(qbitUrl, data=data)

I have also tried with cURL:
curl -i -d urls='http://www.somelink.to/file.torrent' -d autoTMM=false -d savepath='C:\Downloads\' -d paused=false -d root_folder=true 127.0.0.1:8080/api/v2/torrents/add

@thalieht thalieht added the WebAPI label Oct 3, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.