New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

qbittorrent 3.3.15-1 on Debian testing sometimes hangs and crashes when parsing metadata of a magnet file. #7553

Closed
shirishag75 opened this Issue Oct 7, 2017 · 2 comments

Comments

Projects
None yet
3 participants
@shirishag75

shirishag75 commented Oct 7, 2017

Subject: qbittorrent hangs sometimes while parsing metadata of a magnet file
Package: qbittorrent
Version: 3.3.15-1
Severity: normal

Dear Maintainer,

Qbittorrent sometimes hangs while parsing metadata of a magnet file. Attaching a gdb debug session in hopes it might give something. 


-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (600, 'testing'), (500, 'unstable-debug'), (500, 'testing-debug'), (1, 'experimental-debug'), (1, 'experimental'), (1, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.12.0-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages qbittorrent depends on:
ii  geoip-database         20170928-1
ii  libboost-system1.62.0  1.62.0+dfsg-4+b1
ii  libc6                  2.24-17
ii  libgcc1                1:7.2.0-7
ii  libqt5core5a           5.9.1+dfsg-9
ii  libqt5dbus5            5.9.1+dfsg-9
ii  libqt5gui5             5.9.1+dfsg-9
ii  libqt5network5         5.9.1+dfsg-9
ii  libqt5widgets5         5.9.1+dfsg-9
ii  libqt5xml5             5.9.1+dfsg-9
ii  libstdc++6             7.2.0-7
ii  libtorrent-rasterbar9  1.1.4-1
ii  python                 2.7.13-2
ii  zlib1g                 1:1.2.8.dfsg-5

qbittorrent recommends no packages.

Versions of packages qbittorrent suggests:
ii  qbittorrent-dbg  3.3.15-1

-- no debconf information

Sharing the gdb output as https://gist.github.com/shirishag75/39b6c9fd28211594ac234501e12397b2




@drbree82

This comment has been minimized.

Show comment
Hide comment
@drbree82

drbree82 Oct 14, 2017

Having same problem. Have been putting up with it for approx 4 months. On Debian Stretch 9.1

drbree82 commented Oct 14, 2017

Having same problem. Have been putting up with it for approx 4 months. On Debian Stretch 9.1

@ngosang

This comment has been minimized.

Show comment
Hide comment
@ngosang

ngosang Sep 16, 2018

Member

We are closing all issues related to old qBittorrent versions (qBittorrent < 4.1.0).
Please, update to last release and, if the bug/error/crash is still present, open another issue.
Thank you.

Member

ngosang commented Sep 16, 2018

We are closing all issues related to old qBittorrent versions (qBittorrent < 4.1.0).
Please, update to last release and, if the bug/error/crash is still present, open another issue.
Thank you.

@ngosang ngosang closed this Sep 16, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment