New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Inaccurate reporting of speeds as well as speed throttling problems #7684

Open
Larry456 opened this Issue Nov 8, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@Larry456

Larry456 commented Nov 8, 2017

Please provide the following information

qBittorrent version and Operating System:

Fedora 26, qBittorrent 3.3.16 (also had the problem on 3.3.13)

If on linux, libtorrent and Qt version:

QT: 5.7.1, libtorrent: 1.1.2.0 according to help>about

What is the problem:

The current upload/download speeds (usually seems to affect upload more although I couldn't guess why) being reported by qBittorrent are often inaccurate. Nearly always in terms of upload. For example, over the past few minutes, qBittorrent says it's been uploading at ~100KBps average. In actuality, it's uploading ~450-500KBps (my maximum upload speed) as reported by both the operating system and router itself (as well as the fact that closing qBittorrent causes my computer to upload ~1-4KBps instead of the 500KBps while qBittorrent was running).

qBittorrent is also not working correctly with speed throttling settings. If I try to set a reasonable limit on the upload speed it seems to ignore it completely (I'm assuming this is because qBittorrent THINKS the speeds that it reports are accurate, and is thus thinking the lower upload speeds are below the limit I set). However, if I limit the upload rate to say 1KBps on the torrent itself (right click) this usually seems to work as a temporary solution.

What is the expected behavior:

For the client to report correct speeds and throttle according to them

Steps to reproduce:

N/A, automatic problem

Extra info(if any):

Fedora 26, stable version of qBittorrent 3.3.13 as well as the 3.3.16 I installed are affected.

@Seeker2

This comment has been minimized.

Show comment
Hide comment
@Seeker2

Seeker2 Nov 8, 2017

This sounds very much like:
3.4.0 beta2 total download speed mismatch #7668

Seeker2 commented Nov 8, 2017

This sounds very much like:
3.4.0 beta2 total download speed mismatch #7668

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment