New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

RSS validation bug! #7970

Open
mibj01 opened this Issue Dec 3, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@mibj01

mibj01 commented Dec 3, 2017

Please provide the following information

qBittorrent version and Operating System

v4.02 64-bit Windows 10

If on linux, libtorrent and Qt version

(type here)

What is the problem

When adding an RSS feed it is marked as invalid even when it is validated and correct.

What is the expected behavior

The RSS feed is read and inserted in the RSS viewer

Steps to reproduce

Add RSS feed: http://libgen.io/rss/index.php
View log and there is a line telling us: Failed to parse RSS feed at 'http://libgen.io/rss/index.php'. Reason: Invalid RSS feed.

Extra info(if any)

This particular RSS feed is validated as a correct feed by using the W3C Validation service:
https://validator.w3.org/feed/check.cgi?url=http%3A%2F%2Flibgen.io%2Frss%2Findex.php#l520

There is a couple of "minor issues" but the feed is accepted as correct!

@gmusgrave

This comment has been minimized.

Show comment
Hide comment
@gmusgrave

gmusgrave Jan 26, 2018

I have the same problem with V4.03. My feed validates, but qbittorrent rejects it!

My feed is here: http://jaliscocondos.org/corrie/corrie_pb_rss.php

This feed was working before.

gmusgrave commented Jan 26, 2018

I have the same problem with V4.03. My feed validates, but qbittorrent rejects it!

My feed is here: http://jaliscocondos.org/corrie/corrie_pb_rss.php

This feed was working before.

@gmusgrave

This comment has been minimized.

Show comment
Hide comment
@gmusgrave

gmusgrave Jan 27, 2018

More info....

I tried shutting down qbittorrent and restarting it... the RSS feed started working again.

gmusgrave commented Jan 27, 2018

More info....

I tried shutting down qbittorrent and restarting it... the RSS feed started working again.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment