New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Sort on country does not work on 4.03 #8253

Closed
Ozman opened this Issue Jan 11, 2018 · 3 comments

Comments

Projects
None yet
3 participants
@Ozman

Ozman commented Jan 11, 2018

Please provide the following information

qBittorrent version and Operating System

4.03 x64

If on linux, libtorrent and Qt version

lib64torrent-rasterbar 8 & 9, Qt5.10

What is the problem

In the lower window of QBT, the sort on country column no longer works.

What is the expected behavior

Clicking on the column header will sort the countries a-z or z-a

Steps to reproduce

Just click on country column header

Extra info(if any)

Was working well on all previous versions for as long as I can remember.

@FranciscoPombal

This comment has been minimized.

Show comment
Hide comment
@FranciscoPombal

FranciscoPombal Jan 16, 2018

Contributor

What is your operating system? You said it is x64, but is it windows 10, Linux, or something else?
I was able to reproduce this issue on a clean installation of qBittorrent 4.0.3 x64 on Windows 10 (latest updates).

Contributor

FranciscoPombal commented Jan 16, 2018

What is your operating system? You said it is x64, but is it windows 10, Linux, or something else?
I was able to reproduce this issue on a clean installation of qBittorrent 4.0.3 x64 on Windows 10 (latest updates).

@FranciscoPombal

This comment has been minimized.

Show comment
Hide comment
@FranciscoPombal

FranciscoPombal Jan 16, 2018

Contributor

Just to clarify, it's not that the button does not work, the issue is that when clicking, the flags do't get sorted, they just get rearranged in a seemingly random order.

Contributor

FranciscoPombal commented Jan 16, 2018

Just to clarify, it's not that the button does not work, the issue is that when clicking, the flags do't get sorted, they just get rearranged in a seemingly random order.

@thalieht

This comment has been minimized.

Show comment
Hide comment
@thalieht

thalieht Jan 16, 2018

Contributor

It's fixed in 4.0.4 (unreleased).

Contributor

thalieht commented Jan 16, 2018

It's fixed in 4.0.4 (unreleased).

@thalieht thalieht closed this Jul 28, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment