New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Windows] Does not start when %temp% folder is unavailable #9474

Open
AndyScull opened this Issue Sep 10, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@AndyScull

AndyScull commented Sep 10, 2018

qBittorrent version and Operating System

qBittorrent v 4.1.2
Windows 7 SP1 x64

What is the problem

Small problem, I doubt anyone else would encounter it but nonetheless there should be some kind or error output here. I found it when I replaced my HDD and tried to start qBittorrent before changing %temp% env variable to new drive letter.
When the %temp% folder does not exist then qBittorrent silently closes on start, without any error or log message. After starting it would appear in process list for a moment and then exit. No error message on screen, in log file or in windows events so there's no indication what happens. Only after tracing the process with procmon I could find the reason for this behavior

What is the expected behavior

Error message on screen or in log file (%localappdata%\qBittorrent\logs\qbittorrent.log)

Steps to reproduce

Set windows environment variable %temp% to non-existing folder or delete existing temp folder.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment