Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

qBittorrent v4.1.4 WebUI blank when no locale set #9978

Closed
MarkusMcNugen opened this Issue Dec 8, 2018 · 1 comment

Comments

Projects
None yet
2 participants
@MarkusMcNugen
Copy link

MarkusMcNugen commented Dec 8, 2018

Please provide the following information

qBittorrent version and Operating System

qBittorrent v4.1.4
Ubuntu 18.04 x64

If on linux, libtorrent and Qt version

Qt 5.9.5
libtorrent 1.1.11

What is the problem

If no locale is set in qBittorrent.conf the WebUI loads with no text instead of defaulting to the en locale.

What is the expected behavior

WebUI loads with english as the default locale when none is configured

Steps to reproduce

Set locale to blank in qBittorrent.conf, start qBittorrent and load the WebUI, e.g. General\Locale=

Extra info(if any)

This error did not appear until v4.1.4 when this started showing in the logs "Couldn't load Web UI translation for selected locale (C). Falling back to default (en)."

@MarkusMcNugen MarkusMcNugen changed the title qBittorrent v4.1.4 WebUI blank when no default locale set qBittorrent v4.1.4 WebUI blank when no locale set Dec 8, 2018

@Piccirello

This comment has been minimized.

Copy link
Contributor

Piccirello commented Dec 8, 2018

This was fixed in #9891 and will be part of 4.1.5

@Piccirello Piccirello closed this Dec 8, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.