Skip to content
Permalink
Browse files

pyqtwrapper: set sip api to 2 for PyQt.QtCore for Qt4

(followup fb3fcfa)
  • Loading branch information
jef-n committed Mar 15, 2016
1 parent 567a323 commit 01c2cfbe878840e2f048e5332f3fff37f22ab1da
Showing with 10 additions and 0 deletions.
  1. +10 −0 python/PyQt/PyQt4/QtCore.py
@@ -23,6 +23,16 @@
# This will get replaced with a git SHA1 when you do a git archive
__revision__ = '$Format:%H$'

import sip

try:
apis = ["QDate", "QDateTime", "QString", "QTextStream", "QTime", "QUrl", "QVariant"]
for api in apis:
sip.setapi(api, 2)
except ValueError:
# API has already been set so we can't set it again.
pass

from PyQt4.QtCore import *
from PyQt4.QtGui import QItemSelectionModel, QSortFilterProxyModel

0 comments on commit 01c2cfb

Please sign in to comment.
You can’t perform that action at this time.