Skip to content
Permalink
Browse files

Require Qt >= 5.8 when 3D support is enabled

  • Loading branch information
wonder-sk committed Sep 27, 2017
1 parent 2b31127 commit 041704e572d8cd0960f850aa3244a8440e454372
Showing with 7 additions and 1 deletion.
  1. +7 −1 CMakeLists.txt
@@ -260,7 +260,13 @@ IF(WITH_CORE)
ENDIF(WITH_QTWEBKIT)
#############################################################
# search for Qt5
SET(QT_MIN_VERSION 5.2.0)
IF (WITH_3D)
# for 3D support we strictly require Qt >= 5.8
# (Qt 3D was introduced in 5.7 but it is not stable enough in that branch)
SET(QT_MIN_VERSION 5.8.0)
ELSE ()
SET(QT_MIN_VERSION 5.2.0)
ENDIF()
FIND_PACKAGE(Qt5Core QUIET)
FIND_PACKAGE(Qt5Gui REQUIRED)
FIND_PACKAGE(Qt5Widgets REQUIRED)

0 comments on commit 041704e

Please sign in to comment.
You can’t perform that action at this time.