Skip to content
Permalink
Browse files

Less postgis voodoo on travis

  • Loading branch information
m-kuhn committed Jul 25, 2015
1 parent c77db4f commit 0966dadc7953385e5fb2d4857006fd2d7d442756
Showing with 4 additions and 4 deletions.
  1. +4 −4 .travis.yml
@@ -23,14 +23,13 @@ addons:
postgresql: "9.1"

before_install:
- export DEBIAN_FRONTEND=noninteractive
- sudo add-apt-repository ppa:ubuntugis/ppa -y
- sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable -y # For postgresql-9.1-postgis-2.1
- sudo add-apt-repository ppa:smspillaz/cmake-3.0.2 -y
- sudo add-apt-repository ppa:kedazo/doxygen-updates-precise -y # For doxygen 1.8.8
- sudo rm -f /etc/apt/sources.list.d/pgdg-source.list # postgis from pgdg requires different gdal package than the grass package
- sudo apt-get update -qq
- sudo apt-get remove postgresql-9.1-postgis-2.1 # Remove postgis from pgdg, will install postgis from ubuntugis-unstable instead
- sudo apt-get install --no-install-recommends
- sudo apt-get install --force-yes --no-install-recommends --no-install-suggests
bison cmake cmake-data doxygen flex git graphviz
grass-dev libexpat1-dev libfcgi-dev libgdal1-dev
libgeos-dev libgsl0-dev libpq-dev libproj-dev
@@ -41,7 +40,8 @@ before_install:
python python-dev python-qt4 python-qt4-dev
python-sip python-sip-dev spawn-fcgi txt2tags
xauth xfonts-100dpi xfonts-75dpi xfonts-base
xfonts-scalable xvfb postgresql-9.1-postgis-2.1
xfonts-scalable xvfb
postgresql-9.1-postgis-2.1/precise # postgis one from ubuntugis-unstable, not pgdg
- cmake --version
- clang --version

0 comments on commit 0966dad

Please sign in to comment.
You can’t perform that action at this time.