Skip to content
Permalink
Browse files

Merge pull request #9060 from daniviga/release-3_4

[RPM] Backport some fixes for master, add F30+ compatibility
  • Loading branch information
m-kuhn committed Feb 1, 2019
2 parents 174dc4b + 1ea7699 commit 0e635828d9ae008f3694b30b9395c5a2c13aee08
Showing with 20 additions and 8 deletions.
  1. +20 −8 rpm/qgis.spec.template
@@ -12,16 +12,22 @@
# py files located under /usr/share/qgis/python/plugins
%global __python %{__python3}

%if 0%{?fedora} >= 30
%define grass grass76
%else
%define grass grass74
%endif

%if %{_timestamp} > 0
# Epoch is set only when building packages from master
Epoch: %{_timestamp}
%define combinedversion %{epoch}:%{version}
%define builddate %(date -d @%{_timestamp} '+%a %b %d %Y')
%else
%define combinedversion %{version}
%define builddate %(date '+%a %b %d %Y')
%endif

%define grass grass74

Name: qgis
Version: %{_version}
Release: %{_relver}%{?dist}
@@ -64,10 +70,13 @@ BuildRequires: spatialindex-devel
BuildRequires: grass-devel

# Other stuff
BuildRequires: exiv2-devel
BuildRequires: gsl-devel
BuildRequires: libzip-devel
BuildRequires: postgresql-devel
BuildRequires: sqlite-devel
BuildRequires: hdf5-devel
BuildRequires: netcdf-devel
BuildRequires: fcgi-devel

# OpenCL
@@ -130,14 +139,14 @@ and USGS ASCII DEM.

%package devel
Summary: Development Libraries for the QGIS
Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}
Requires: %{name}%{?_isa} = %{combinedversion}-%{release}

%description devel
Development packages for QGIS including the C header files.

%package grass
Summary: GRASS Support Libraries for QGIS
Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}
Requires: %{name}%{?_isa} = %{combinedversion}-%{release}

# The plug-in requires more than just the grass-libs.
# This questions the sense of the libs package.
@@ -152,12 +161,12 @@ GRASS plugin for QGIS required to interface with the GRASS system.
%package -n python3-qgis
%{?python_provide:%python_provide python3-qgis}
# Remove before F30
Provides: %{name}-python = %{version}-%{release}
Provides: %{name}-python%{?_isa} = %{version}-%{release}
Provides: %{name}-python = %{combinedversion}-%{release}
Provides: %{name}-python%{?_isa} = %{combinedversion}-%{release}
Obsoletes: %{name}-python < %{version}-%{release}
Obsoletes: python2-%{name} < %{version}-%{release}
Summary: Python integration and plug-ins for QGIS
Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}
Requires: %{name}%{?_isa} = %{combinedversion}-%{release}
Requires: gdal-python3
Requires: python3-future
Requires: python3-jinja2
@@ -175,7 +184,7 @@ Python integration and plug-ins for QGIS.

%package server
Summary: FCGI-based OGC web map server
Requires: %{name}%{?_isa} = %{epoch}:%{version}-%{release}
Requires: %{name}%{?_isa} = %{combinedversion}-%{release}
Requires: mod_fcgid
Provides: mapserver = %{version}-%{release}
Obsoletes: mapserver < 2.8.1-1
@@ -244,6 +253,8 @@ rm -f %{buildroot}%{_datadir}/%{name}/doc/INSTALL*

%find_lang %{name} --with-qt

# TODO: Remove after F28 EoL
# Ref: https://fedoraproject.org/wiki/Changes/RemoveObsoleteScriptlets
%post
/sbin/ldconfig
touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
@@ -269,6 +280,7 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
%post -n python3-qgis -p /sbin/ldconfig

%postun -n python3-qgis -p /sbin/ldconfig
# END TODO #

%files -f %{name}.lang
%doc BUGS NEWS Exception_to_GPL_for_Qt.txt ChangeLog.gz

0 comments on commit 0e63582

Please sign in to comment.
You can’t perform that action at this time.