Skip to content
Permalink
Browse files
debian packaging fixes
git-svn-id: http://svn.osgeo.org/qgis/trunk/qgis@14119 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
jef committed Aug 22, 2010
1 parent 4c1a95f commit 11585b26dc777507aab006acc2d71ccd2109479d
Showing with 62 additions and 53 deletions.
  1. +4 −3 debian/control.hardy
  2. +8 −6 debian/control.intrepid
  3. +7 −5 debian/control.jaunty
  4. +7 −5 debian/control.karmic
  5. +8 −6 debian/control.lenny
  6. +6 −7 debian/control.lucid
  7. +8 −7 debian/control.maverick
  8. +7 −7 debian/control.sid
  9. +7 −7 debian/control.squeeze
@@ -3,9 +3,10 @@ Section: science
Priority: extra
Maintainer: Quantum GIS developers <qgis-developer@lists.osgeo.org>
Build-Depends: debhelper (>= 5.0.51~), libgdal1-dev, libpq-dev,
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, proj, libexpat1-dev,
flex, bison, python-dev, cmake (>=2.4.3), python-sip4 (>= 4.5.0), python-central (>=0.5), python,
sip4 (>= 4.5), libqt4-core (>=4.2.0), libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0),
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, proj,
libexpat1-dev, flex, bison, python-dev, cmake (>=2.4.3),
python-sip4 (>= 4.5.0), python-central (>=0.5), python, sip4 (>= 4.5),
libqt4-core (>=4.2.0), libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0),
libqt4-sql (>=4.2.0), python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0),
python-sip4-dev (>= 4.5.0), pyqt4-dev-tools, fcgi-dev, subversion
Build-Conflicts: libqgis-dev, qgis-dev
@@ -3,19 +3,21 @@ Section: science
Priority: extra
Maintainer: Quantum GIS developers <qgis-developer@lists.osgeo.org>
Build-Depends: debhelper (>= 5.0.51~), libgdal1-dev, libpq-dev,
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, proj, libexpat1-dev,
flex, bison, python-dev, cmake (>=2.4.3), python-sip4 (>= 4.5.0), python-central (>=0.5), python,
sip4 (>= 4.5), libqt4-core (>=4.2.0), libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0),
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, proj,
libexpat1-dev, flex, bison, python-dev, cmake (>=2.4.3),
python-sip4 (>= 4.5.0), python-central (>=0.5), python, sip4 (>= 4.5),
libqt4-core (>=4.2.0), libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0),
libqt4-sql (>=4.2.0), python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0),
python-sip4-dev (>= 4.5.0), pyqt4-dev-tools, libqwt5-qt4-dev, libfcgi-dev, subversion
python-sip4-dev (>= 4.5.0), pyqt4-dev-tools, libqwt5-qt4-dev, libfcgi-dev,
subversion
Build-Conflicts: libqgis-dev, qgis-dev
Standards-Version: 3.8.0
XS-Python-Version: current
Homepage: http://qgis.org/

Package: qgis
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-common (= ${source:Version})
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-providers (= ${binary:Version}), qgis-common (= ${source:Version})
Recommends: qgis-plugin-grass, python-qgis
Suggests: gpsbabel
Conflicts: uim-qt3
@@ -59,7 +61,7 @@ Depends: libqgis{QGIS_ABI} (= ${binary:Version}), libgdal1-dev,
libqt4-sql (>=4.2.0), python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0),
qt4-designer (>=4.2.0)
Provides: qgis-dev
Replaces: libqgis-dev, qgis-dev, libqgis1-dev
Replaces: qgis-dev, libqgis1-dev
Description: Quantum GIS - development files
Quantum GIS is a Geographic Information System (GIS) which manages, analyzes
and display databases of geographic information.
@@ -3,19 +3,21 @@ Section: science
Priority: extra
Maintainer: Quantum GIS developers <qgis-developer@lists.osgeo.org>
Build-Depends: debhelper (>= 5.0.51~), libgdal1-dev, libpq-dev,
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, proj, libexpat1-dev,
flex, bison, python-dev, cmake (>=2.4.3), python-sip4 (>= 4.5.0), python-central (>=0.5), python,
sip4 (>= 4.5), libqt4-core (>=4.2.0), libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0),
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, proj,
libexpat1-dev, flex, bison, python-dev, cmake (>=2.4.3),
python-sip4 (>= 4.5.0), python-central (>=0.5), python, sip4 (>= 4.5),
libqt4-core (>=4.2.0), libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0),
libqt4-sql (>=4.2.0), python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0),
python-sip4-dev (>= 4.5.0), pyqt4-dev-tools, libqwt5-qt4-dev, libfcgi-dev, subversion
python-sip4-dev (>= 4.5.0), pyqt4-dev-tools, libqwt5-qt4-dev, libfcgi-dev,
subversion
Build-Conflicts: libqgis-dev, qgis-dev
Standards-Version: 3.8.0
XS-Python-Version: current
Homepage: http://qgis.org/

Package: qgis
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-common (= ${source:Version})
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-providers (= ${binary:Version}), qgis-common (= ${source:Version})
Recommends: qgis-plugin-grass, python-qgis
Suggests: gpsbabel
Conflicts: uim-qt3
@@ -3,19 +3,21 @@ Section: science
Priority: extra
Maintainer: Quantum GIS developers <qgis-developer@lists.osgeo.org>
Build-Depends: debhelper (>= 5.0.51~), libgdal1-dev, libpq-dev,
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, proj, libexpat1-dev,
flex, bison, python-dev, cmake (>=2.4.3), python-sip4 (>= 4.5.0), python-central (>=0.5), python,
sip4 (>= 4.5), libqt4-core (>=4.2.0), libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0),
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, proj,
libexpat1-dev, flex, bison, python-dev, cmake (>=2.4.3),
python-sip4 (>= 4.5.0), python-central (>=0.5), python, sip4 (>= 4.5),
libqt4-core (>=4.2.0), libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0),
libqt4-sql (>=4.2.0), python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0),
python-sip4-dev (>= 4.5.0), pyqt4-dev-tools, libqwt5-qt4-dev, libfcgi-dev, subversion
python-sip4-dev (>= 4.5.0), pyqt4-dev-tools, libqwt5-qt4-dev, libfcgi-dev,
subversion
Build-Conflicts: libqgis-dev, qgis-dev
Standards-Version: 3.8.0
XS-Python-Version: current
Homepage: http://qgis.org/

Package: qgis
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-common (= ${source:Version})
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-providers (= ${binary:Version}), qgis-common (= ${source:Version})
Recommends: qgis-plugin-grass, python-qgis
Suggests: gpsbabel
Conflicts: uim-qt3
@@ -3,19 +3,21 @@ Section: science
Priority: extra
Maintainer: Quantum GIS developers <qgis-developer@lists.osgeo.org>
Build-Depends: debhelper (>= 5.0.51~), libgdal1-dev, libpq-dev,
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, proj, libexpat1-dev,
flex, bison, python-dev, cmake (>=2.4.3), python-sip4 (>= 4.5.0), python-central (>=0.5), python,
sip4 (>= 4.5), libqt4-core (>=4.2.0), libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0),
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, proj,
libexpat1-dev, flex, bison, python-dev, cmake (>=2.4.3),
python-sip4 (>= 4.5.0), python-central (>=0.5), python, sip4 (>= 4.5),
libqt4-core (>=4.2.0), libqt4-dev (>=4.2.0), libqt4-gui (>=4.2.0),
libqt4-sql (>=4.2.0), python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0),
python-sip4-dev (>= 4.5.0), pyqt4-dev-tools, libqwt5-qt4-dev, pkg-config, libfcgi-dev, subversion
python-sip4-dev (>= 4.5.0), pyqt4-dev-tools, libqwt5-qt4-dev, pkg-config,
libfcgi-dev, subversion
Build-Conflicts: libqgis-dev, qgis-dev
Standards-Version: 3.8.0
XS-Python-Version: current
Homepage: http://qgis.org/

Package: qgis
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-common (= ${source:Version})
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-providers (= ${binary:Version}), qgis-common (= ${source:Version})
Recommends: qgis-plugin-grass, python-qgis
Suggests: gpsbabel
Conflicts: uim-qt3
@@ -104,8 +106,8 @@ Description: Python bindings to Quantum GIS
Package: python-qgis-common
Section: python
Architecture: all
Depends: gdal-bin, python-gdal
Provides: ${python:Provides}
Depends: gdal-bin, python-gdal
XB-Python-Version: ${python:Versions}
Description: Python bindings to Quantum GIS - architecture-independent files
Quantum GIS is a Geographic Information System (GIS) which manages, analyzes
@@ -3,20 +3,19 @@ Section: science
Priority: extra
Maintainer: Quantum GIS developers <qgis-developer@lists.osgeo.org>
Build-Depends: debhelper (>= 7), libgdal1-dev, libpq-dev,
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, libproj-dev, libexpat1-dev,
flex, bison, python-dev, cmake (>= 2.6), python-sip (>= 4.5.0), python-central (>=0.5), python,
libqt4-core (>=4.4.0), libqt4-dev (>=4.4.0), libqt4-gui (>=4.4.0),
libqt4-sql (>=4.4.0), python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0),
python-sip-dev (>= 4.5.0), pyqt4-dev-tools, libqwt5-qt4-dev, libspatialite-dev,
libfcgi-dev, subversion
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, libproj-dev,
libexpat1-dev, flex, bison, python-dev, cmake (>= 2.6), python-sip (>= 4.5.0), python-central (>=0.5), python, libqt4-core (>=4.4.0), libqt4-dev (>=4.4.0),
libqt4-gui (>=4.4.0), libqt4-sql (>=4.4.0), python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0), python-sip-dev (>= 4.5.0), pyqt4-dev-tools,
libqwt5-qt4-dev, libspatialite-dev, libfcgi-dev, pkg-config, subversion
Build-Conflicts: libqgis-dev, qgis-dev
Standards-Version: 3.8.4
XS-Python-Version: current
Homepage: http://qgis.org/

Package: qgis
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-common (= ${source:Version})
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-providers (= ${binary:Version}), qgis-common (= ${source:Version})
Recommends: qgis-plugin-grass, python-qgis
Suggests: gpsbabel
Conflicts: uim-qt3
@@ -3,20 +3,21 @@ Section: science
Priority: extra
Maintainer: Quantum GIS developers <qgis-developer@lists.osgeo.org>
Build-Depends: debhelper (>= 7), libgdal1-dev, libpq-dev,
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, libproj-dev, libexpat1-dev,
flex, bison, python-dev, cmake (>= 2.6), python-sip (>= 4.5.0), python-central (>=0.5), python,
libqt4-core (>=4.4.0), libqt4-dev (>=4.4.0), libqt4-gui (>=4.4.0),
libqt4-sql (>=4.4.0), libqtwebkit-dev,
python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0), python-sip-dev (>= 4.5.0), pyqt4-dev-tools,
libqwt5-qt4-dev, libspatialite-dev, subversion
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, libproj-dev,
libexpat1-dev, flex, bison, python-dev, cmake (>= 2.6), python-sip (>= 4.5.0),
python-central (>=0.5), python, libqt4-core (>=4.4.0), libqt4-dev (>=4.4.0),
libqt4-gui (>=4.4.0), libqt4-sql (>=4.4.0), libqtwebkit-dev,
python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0), python-sip-dev (>= 4.5.0),
pyqt4-dev-tools, libqwt5-qt4-dev, libspatialite-dev, libfcgi-dev, pkg-config,
subversion
Build-Conflicts: libqgis-dev, qgis-dev
Standards-Version: 3.8.4
XS-Python-Version: current
Homepage: http://qgis.org/

Package: qgis
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-common (= ${source:Version})
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-providers (= ${binary:Version}), qgis-common (= ${source:Version})
Recommends: qgis-plugin-grass, python-qgis
Suggests: gpsbabel
Conflicts: uim-qt3
@@ -3,20 +3,20 @@ Section: science
Priority: extra
Maintainer: Quantum GIS developers <qgis-developer@lists.osgeo.org>
Build-Depends: debhelper (>= 7), libgdal1-dev, libpq-dev,
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, libproj-dev, libexpat1-dev,
flex, bison, python-dev, cmake (>= 2.6), python-sip (>= 4.5.0), python-central (>=0.5), python,
libqt4-core (>=4.4.0), libqt4-dev (>=4.4.0), libqt4-gui (>=4.4.0),
libqt4-sql (>=4.4.0), python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0),
python-sip-dev (>= 4.5.0), pyqt4-dev-tools, libqwt5-qt4-dev, libspatialite-dev,
pkg-config, subversion
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, libproj-dev,
libexpat1-dev, flex, bison, python-dev, cmake (>= 2.6), python-sip (>= 4.5.0),
python-central (>=0.5), python, libqt4-core (>=4.4.0), libqt4-dev (>=4.4.0),
libqt4-gui (>=4.4.0), libqt4-sql (>=4.4.0), python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0), python-sip-dev (>= 4.5.0), pyqt4-dev-tools,
libqwt5-qt4-dev, libspatialite-dev, libfcgi-dev, pkg-config, subversion
Build-Conflicts: libqgis-dev, qgis-dev
Standards-Version: 3.8.4
XS-Python-Version: current
Homepage: http://qgis.org/

Package: qgis
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-common (= ${source:Version}), qgis-providers (= ${binary:Version})
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-providers (= ${binary:Version}), qgis-common (= ${source:Version})
Recommends: qgis-plugin-grass, python-qgis
Suggests: gpsbabel
Conflicts: uim-qt3
@@ -3,20 +3,20 @@ Section: science
Priority: extra
Maintainer: Quantum GIS developers <qgis-developer@lists.osgeo.org>
Build-Depends: debhelper (>= 7), libgdal1-dev, libpq-dev,
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, libproj-dev, libexpat1-dev,
flex, bison, python-dev, cmake (>= 2.6), python-sip (>= 4.5.0), python-central (>=0.5), python,
libqt4-core (>=4.4.0), libqt4-dev (>=4.4.0), libqt4-gui (>=4.4.0),
libqt4-sql (>=4.4.0), python-qt4 (>=4.1.0), python-qt4-dev (>=4.1.0),
python-sip-dev (>= 4.5.0), pyqt4-dev-tools, libqwt5-qt4-dev, libspatialite-dev,
pkg-config, subversion
libgeos-dev (>= 3.0.0), grass-dev, libsqlite3-dev, libgsl0-dev, libproj-dev,
libexpat1-dev, flex, bison, python-dev, cmake (>= 2.6), python-sip (>= 4.5.0),
python-central (>=0.5), python, libqt4-core (>=4.4.0), libqt4-dev (>=4.4.0),
libqt4-gui (>=4.4.0), libqt4-sql (>=4.4.0), python-qt4 (>=4.1.0),
python-qt4-dev (>=4.1.0), python-sip-dev (>= 4.5.0), pyqt4-dev-tools,
libqwt5-qt4-dev, libspatialite-dev, libfcgi-dev, pkg-config, subversion
Build-Conflicts: libqgis-dev, qgis-dev
Standards-Version: 3.8.4
XS-Python-Version: current
Homepage: http://qgis.org/

Package: qgis
Architecture: any
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-common (= ${source:Version})
Depends: ${shlibs:Depends}, ${misc:Depends}, qgis-providers (= ${binary:Version}), qgis-common (= ${source:Version})
Recommends: qgis-plugin-grass, python-qgis
Suggests: gpsbabel
Conflicts: uim-qt3

0 comments on commit 11585b2

Please sign in to comment.