Skip to content
Permalink
Browse files
QgsOgrProvider::open(): remove useless GDAL version check
  • Loading branch information
rouault committed May 24, 2021
1 parent 92709e8 commit 11e2ba857f77f06dc12f474027ef126965a45f7a
Showing with 2 additions and 4 deletions.
  1. +2 −4 src/core/providers/ogr/qgsogrprovider.cpp
@@ -5347,11 +5347,9 @@ void QgsOgrProvider::open( OpenMode mode )
mValid = false;

// In the case where we deal with a shapefile, it is possible that it has
// pre-existing holes in the DBF (see #15407), so if using a GDAL version
// recent enough to have reliable packing, do a packing at the first edit
// pre-existing holes in the DBF (see #15407), so do a packing at the first edit
// action.
if ( mGDALDriverName == QLatin1String( "ESRI Shapefile" ) &&
atoi( GDALVersionInfo( "VERSION_NUM" ) ) >= GDAL_COMPUTE_VERSION( 2, 1, 2 ) )
if ( mGDALDriverName == QLatin1String( "ESRI Shapefile" ) )
{
mShapefileMayBeCorrupted = true;
}

0 comments on commit 11e2ba8

Please sign in to comment.