Skip to content
Permalink
Browse files
debian packaging: remove python-owslib from python-qgis dependencies
    on trusty
  • Loading branch information
jef-n committed Mar 28, 2017
1 parent 4d5a9fe commit 140a01fc9bc91a541086fd4b4360cc9ef7ebb5df
Showing with 19 additions and 19 deletions.
  1. +19 −19 debian/control.in
@@ -6,28 +6,27 @@ Priority: optional
Build-Depends:
bison,
cmake (>= 2.8),
#sid stretch jessie trusty xenial yakkety# debhelper (>= 9),
#sid stretch jessie trusty xenial yakkety# dh-python,
debhelper (>= 9), dh-python,
flex,
grass-dev,
libexpat1-dev,
libfcgi-dev,
#sid stretch jessie trusty xenial yakkety# libgdal-dev (>= 1.10.1-0~),
libgdal-dev (>= 1.10.1-0~),
gdal-bin,
python-gdal,
libgeos-dev (>= 3.0.0),
#jessie trusty# libgsl0-dev,
#sid stretch xenial yakkety# libgsl-dev,
# jessie trusty # libgsl0-dev,
#sid stretch xenial yakkety# libgsl-dev,
libpq-dev,
libproj-dev,
libqt4-dev (>= 4.7.0),
libqt4-opengl-dev,
libqca2-dev,
libqca2-plugin-ossl,
libqtwebkit-dev,
#stretch jessie# libqwt-dev,
#trusty xenial yakkety sid# libqwt5-qt4-dev,
#sid stretch jessie trusty xenial yakkety# libqjson-dev,
# jessie stretch # libqwt-dev,
#sid trusty xenial yakkety# libqwt5-qt4-dev,
libqjson-dev,
libspatialite-dev,
libsqlite3-dev,
libspatialindex-dev,
@@ -38,11 +37,9 @@ Build-Depends:
python-qt4-dev,
python-qt4-sql,
python-yaml, python-mock,
#stretch sid xenial yakkety# python-future,
#sid stretch jessie trusty xenial yakkety# python-all (>= 2.6.6-3~), python-all-dev (>= 2.6.6-3~),
#sid stretch jessie xenial yakkety# pyqt4.qsci-dev,
#sid stretch jessie trusty xenial yakkety# python-pyspatialite,
#sid jessie stretch xenial yakkety# python-nose2,
python-all (>= 2.6.6-3~), python-all-dev (>= 2.6.6-3~), python-pyspatialite,
#sid stretch xenial yakkety# python-future,
#sid jessie stretch xenial yakkety# pyqt4.qsci-dev, python-nose2,
python-sip (>= 4.5.0),
python-sip-dev (>= 4.5.0),
libosgearth-dev,
@@ -236,10 +233,10 @@ Section: libdevel
Depends:
grass-dev,
libexpat1-dev,
#sid stretch jessie trusty xenial yakkety# libgdal-dev (>= 1.10.1-0~),
libgdal-dev (>= 1.10.1-0~),
libgeos-dev (>= 3.0.0),
#jessie trusty# libgsl0-dev,
#sid stretch xenial yakkety# libgsl-dev,
# jessie trusty # libgsl0-dev,
#sid stretch xenial yakkety# libgsl-dev,
libpq-dev,
libproj-dev,
libqgis-app{QGIS_ABI} (= ${binary:Version}),
@@ -371,9 +368,12 @@ Depends:
python-jinja2,
python-pygments,
python-requests,
#!trusty# python-markupsafe, python-dateutil, python-yaml,
#stretch sid xenial yakkety# python-future,
#sid stretch jessie trusty xenial yakkety# python-owslib, python-tz, python-pyproj, python-six, python-pyspatialite,
python-tz,
python-pyproj,
python-six,
python-pyspatialite,
#sid stretch xenial yakkety# python-future,
#sid stretch jessie xenial yakkety# python-markupsafe, python-dateutil, python-yaml, python-owslib,
libqgispython{QGIS_ABI},
${shlibs:Depends},
${python:Depends},

0 comments on commit 140a01f

Please sign in to comment.