Skip to content
Permalink
Browse files

[processing] More verbose error when unsupported SAGA version found

  • Loading branch information
nyalldawson committed Apr 30, 2018
1 parent 27714fc commit 16106b8cfa9e208a7fe609a2f75e6f1547717d3e
Showing with 4 additions and 2 deletions.
  1. +4 −2 python/plugins/processing/algs/saga/SagaAlgorithmProvider.py
@@ -43,6 +43,8 @@
pluginPath = os.path.normpath(os.path.join(
os.path.split(os.path.dirname(__file__))[0], os.pardir))

REQUIRED_VERSION = '2.3.'


class SagaAlgorithmProvider(QgsProcessingProvider):

@@ -85,8 +87,8 @@ def loadAlgorithms(self):
self.tr('Processing'), Qgis.Critical)
return

if not version.startswith('2.3.'):
QgsMessageLog.logMessage(self.tr('Problem with SAGA installation: unsupported SAGA version found.'),
if not version.startswith(REQUIRED_VERSION):
QgsMessageLog.logMessage(self.tr('Problem with SAGA installation: unsupported SAGA version (found: {}, required: {}).').format(version, REQUIRED_VERSION),
self.tr('Processing'),
Qgis.Critical)
return

0 comments on commit 16106b8

Please sign in to comment.
You can’t perform that action at this time.