Skip to content
Permalink
Browse files

Added Martins summary list of QGIS dependencies

git-svn-id: http://svn.osgeo.org/qgis/trunk@7367 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
timlinux
timlinux committed Nov 10, 2007
1 parent 2a8d030 commit 17ba5c8ee1d6d9149d09e9f79620bfd13a3d5eb8
Showing with 58 additions and 6 deletions.
  1. +31 −4 INSTALL
  2. +27 −2 INSTALL.t2t
35 INSTALL
@@ -4,7 +4,8 @@
------------------------------------------------------------------------

1. Introduction
2. General Build Note
2. General Build Notes
2.1. An overview of the dependencies required for building
3. Building under windows using msys
3.1. MSYS:
3.2. Qt4.3
@@ -125,12 +126,12 @@ place for describing build procefures. Please do not remove this notice.
simply copy the commands listed in codeblocks that look like this:


somecommand to be pasted ```
somecommand to be pasted



2. General Build Note
=====================
2. General Build Notes
======================

At version 0.8.1 QGIS no longer uses the autotools for building. QGIS, like a
number of major projects (eg. KDE 4.0), now uses cmake for building from
@@ -141,6 +142,32 @@ For complete information, see the wiki at:
http://wiki.qgis.org/qgiswiki/Building_with_CMake


2.1. An overview of the dependencies required for building
==========================================================

'''Required build deps:'''
* CMake >= 2.4.3
* Flex, Bison

'''Required runtime deps:'''
* Qt >= 4.2.0
* Proj >= ? (known to work with 4.4.x)
* GEOS >= 2.2 (3.0 is supported, maybe 2.1.x works too)
* Sqlite3 >= ? (probably 3.0.0)
* GDAL/OGR >= ? (1.2.x should work)

'''Optional dependencies:'''
* for GRASS plugin - GRASS >= 6.0.0
* for georeferencer - GSL >= ? (works with 1.8)
* for postgis support and SPIT plugin - PostgreSQL >= ?
* for gps plugin - expat >= ? (1.95 is OK)
* for mapserver export and PyQGIS - Python >= ? (probably 2.3)
* for PyQGIS - SIP >= 4.5, PyQt >= 4.1

'''Recommended runtime deps:'''
* for gps plugin - gpsbabel


3. Building under windows using msys
====================================

@@ -55,9 +55,11 @@ place for describing build procefures. Please do not remove this notice.
/!\ ***Note:*** This is a 'cut and paste' tutorial - in most cases you can
simply copy the commands listed in codeblocks that look like this:

``` somecommand to be pasted ```
```
somecommand to be pasted
```

= General Build Note =
= General Build Notes =

At version 0.8.1 QGIS no longer uses the autotools for building. QGIS, like a
number of major projects (eg. KDE 4.0), now uses cmake for building from
@@ -67,6 +69,29 @@ of cmake and provides some clues to build QGIS.
For complete information, see the wiki at:
http://wiki.qgis.org/qgiswiki/Building_with_CMake

== An overview of the dependencies required for building ==

'''Required build deps:'''
* CMake >= 2.4.3
* Flex, Bison

'''Required runtime deps:'''
* Qt >= 4.2.0
* Proj >= ? (known to work with 4.4.x)
* GEOS >= 2.2 (3.0 is supported, maybe 2.1.x works too)
* Sqlite3 >= ? (probably 3.0.0)
* GDAL/OGR >= ? (1.2.x should work)

'''Optional dependencies:'''
* for GRASS plugin - GRASS >= 6.0.0
* for georeferencer - GSL >= ? (works with 1.8)
* for postgis support and SPIT plugin - PostgreSQL >= ?
* for gps plugin - expat >= ? (1.95 is OK)
* for mapserver export and PyQGIS - Python >= ? (probably 2.3)
* for PyQGIS - SIP >= 4.5, PyQt >= 4.1

'''Recommended runtime deps:'''
* for gps plugin - gpsbabel



0 comments on commit 17ba5c8

Please sign in to comment.
You can’t perform that action at this time.