Skip to content
Permalink
Browse files

Default to building WITH_EPT, and show friendly error if WITH_EPT is …

…true but zstd not found
  • Loading branch information
nyalldawson committed Nov 12, 2020
1 parent 3679e9d commit 18976fb40b6e6de4fcea4564dff44b6c62dce81c
Showing with 4 additions and 3 deletions.
  1. +4 −1 CMakeLists.txt
  2. +0 −2 cmake/FindZSTD.cmake
@@ -242,7 +242,7 @@ if(WITH_CORE)
set(HAVE_PDAL TRUE)
endif()

set (WITH_EPT FALSE CACHE BOOL "Determines whether Entwine Point Cloud (EPT) support should be built")
set (WITH_EPT TRUE CACHE BOOL "Determines whether Entwine Point Cloud (EPT) support should be built")
if(WITH_EPT)
set(HAVE_EPT TRUE)
endif()
@@ -390,6 +390,9 @@ if(WITH_CORE)

if (WITH_EPT) # EPT provider
find_package(ZSTD) # for decompression of point clouds
if (NOT ZSTD_FOUND)
message(FATAL_ERROR "ZSTD not found - EPT provider cannot be built")
endif()
find_package(LazPerf) # for decompression of point clouds
if (NOT LazPerf_FOUND)
message(STATUS "Using embedded laz-perf")
@@ -29,6 +29,4 @@ MARK_AS_ADVANCED(ZSTD_LIBRARY ZSTD_INCLUDE_DIR)

IF (ZSTD_FOUND)
MESSAGE(STATUS "Found ZSTD: ${ZSTD_LIBRARY}")
ELSE (ZSTD_FOUND)
MESSAGE(FATAL_ERROR "Could not find ZSTD")
ENDIF (ZSTD_FOUND)

0 comments on commit 18976fb

Please sign in to comment.
You can’t perform that action at this time.