Skip to content
Permalink
Browse files

Make RPM package compatible with Fedora 28

which ships GRASS 7.4
  • Loading branch information
daniviga committed Apr 24, 2018
1 parent aae7a32 commit 1af0f4c7cb87cb64c157b5de5f4b5dc72ba78102
Showing with 7 additions and 1 deletion.
  1. +7 −1 rpm/qgis.spec.template
@@ -12,6 +12,12 @@
%define builddate %(date '+%a %b %d %Y')
%endif

%if 0%{?fedora} >= 28
%define grass grass74
%else
%define grass grass72
%endif

Name: qgis
Version: %{_version}
Release: %{_relver}%{?dist}
@@ -203,7 +209,7 @@ gzip ChangeLog
-D QGIS_CGIBIN_SUBDIR=%{_libexecdir}/%{name} \
-D WITH_BINDINGS:BOOL=TRUE \
-D WITH_GRASS7:BOOL=TRUE \
-D GRASS_PREFIX7=%{_libdir}/grass72 \
-D GRASS_PREFIX7=%{_libdir}/%{grass} \
-D WITH_CUSTOM_WIDGETS:BOOL=TRUE \
-D BINDINGS_GLOBAL_INSTALL:BOOL=TRUE \
-D ENABLE_TESTS:BOOL=FALSE \

0 comments on commit 1af0f4c

Please sign in to comment.
You can’t perform that action at this time.