Skip to content
Permalink
Browse files
python development is not always required (#43212)
* python dev not always required

* simpler approach
  • Loading branch information
3nids committed May 14, 2021
1 parent 32af810 commit 1d88f38b5d783ed53c04dd44cb684f16b50f1355
Showing with 7 additions and 1 deletion.
  1. +7 −1 CMakeLists.txt
@@ -941,7 +941,13 @@ set(QGIS_INSTALL_SYS_LIBS TRUE CACHE BOOL "If set to TRUE install all required s
set(MIN_PYTHON_VERSION "3.7")
set(Python_FIND_FRAMEWORK "LAST")

find_package(Python ${MIN_PYTHON_VERSION} REQUIRED COMPONENTS Interpreter Development)

if (WITH_BINDINGS)
find_package(Python ${MIN_PYTHON_VERSION} REQUIRED COMPONENTS Interpreter Development)
else()
find_package(Python ${MIN_PYTHON_VERSION} REQUIRED COMPONENTS Interpreter)
endif()

message("-- Found Python executable: ${Python_EXECUTABLE} (version ${Python_VERSION})")
message("-- Python library: ${Python_LIBRARIES}")
message("-- Python site-packages: ${Python_SITEARCH}")

0 comments on commit 1d88f38

Please sign in to comment.