Skip to content
Permalink
Browse files

update INSTALL from doc/INSTALL.t2t

git-svn-id: http://svn.osgeo.org/qgis/trunk@9616 c8812cc2-4d05-0410-92ff-de0c093fc19c
  • Loading branch information
jef
jef committed Nov 10, 2008
1 parent 22fb9bb commit 1ed192a68cd522c1caaa7d6c1708dbc53f966f68
Showing with 61 additions and 13 deletions.
  1. +61 −13 INSTALL
74 INSTALL
@@ -49,7 +49,8 @@ Building QGIS from source - step by step
5.7. Prepare your development environment
5.8. Check out the QGIS Source Code
5.9. Starting the compile
5.10. Running QGIS
5.10. Building Debian packages
5.11. Running QGIS
6. Creation of MSYS environment for compilation of Quantum GIS
6.1. Initial setup
6.1.1. MSYS
@@ -150,9 +151,9 @@ simply copy the commands listed in codeblocks that look like this:
======================

At version 0.8.1 QGIS no longer uses the autotools for building. QGIS, like a
number of major projects (eg. KDE 4.0), now uses cmake for building from
source. The configure script in this directory simply checks for the existence
of cmake and provides some clues to build QGIS.
number of major projects (eg. KDE 4.0), now uses cmake (http://www.cmake.org)
for building from source. The configure script in this directory simply checks
for the existence of cmake and provides some clues to build QGIS.

For complete information, see the wiki at:
http://wiki.qgis.org/qgiswiki/Building_with_CMake
@@ -170,16 +171,15 @@ For complete information, see the wiki at:
* Proj >= ? (known to work with 4.4.x)
* GEOS >= 2.2 (3.0 is supported, maybe 2.1.x works too)
* Sqlite3 >= ? (probably 3.0.0)
* GDAL/OGR >= ? (1.2.x should work)
* GDAL/OGR >= 1.4.x (1.2.x should work)

'''Optional dependencies:'''
* for GRASS plugin - GRASS >= 6.0.0
* for georeferencer - GSL >= ? (works with 1.8)
* for postgis support and SPIT plugin - PostgreSQL >= ?
* for postgis support and SPIT plugin - PostgreSQL >= 8.0.x
* for gps plugin - expat >= ? (1.95 is OK)
* for mapserver export and PyQGIS - Python >= ? (probably 2.3)
* for PyQGIS - SIP >= 4.5, PyQt >= 4.1

* for mapserver export and PyQGIS - Python >= 2.3 (2.5+ preferred)
* for PyQGIS - SIP >= 4.5, PyQt >= must match Qt version
'''Recommended runtime deps:'''
* for gps plugin - gpsbabel

@@ -203,7 +203,7 @@ zip archive that contains just about all dependencies.

Get this:

http://qgis.org/uploadfiles/msys/msys.zip
http://download.osgeo.org/qgis/win32/msys.zip

and unpack to c:\msys

@@ -854,7 +854,7 @@ If all built without errors you can then install it:
5.1. Building QGIS with Qt4.x
=============================

Requires: Ubuntu Gutsy / Debian derived distro
Requires: Ubuntu Hardy / Debian derived distro

These notes are current for Ubuntu 7.10 - other versions and Debian derived
distros may require slight variations in package names.
@@ -953,6 +953,12 @@ above commands to select the Qt4 version of the relevant applications.
distributions (e.g. Debian or SuSE) only provide SIP < 4.5 and PyQt4 < 4.1. To include support for python
language bindings you may need to build and install those packages from source.

If you do not have cmake installed already:


sudo apt-get install cmake



5.5. GRASS Specific Steps
=========================
@@ -1038,6 +1044,8 @@ qgis.org certificate. Press 'p' to accept it permanently:
5.9. Starting the compile
=========================

/!\ *Note:* The next section describes howto build debian packages

I compile my development version of QGIS into my ~/apps directory to avoid
conflicts with Ubuntu packages that may be under /usr. This way for example
you can use the binary packages of QGIS on your system along side with your
@@ -1077,7 +1085,46 @@ Now on with the build:
It may take a little while to build depending on your platform.


5.10. Running QGIS
5.10. Building Debian packages
==============================

Instead of creating a personal installation as in the previous step you can
also create debian package. This is done from the qgis root directory, where
you'll find a debian directory.

First you need to install the debian packaging tools once:


apt-get install build-essential


The QGIS packages will be created with:


dpkg-buildpackage -us -us -b


/!\ *Note:* If dpkg-buildpackage complains about unmet build dependencies
you can install them using apt-get and re-run the command.

/!\ *Note:* If you have libqgis1-dev installed, you need to remove it first
using dpkg -r libqgis1-dev. Otherwise dpkg-buildpackage will complain about at
build conflict.

The the packages are created in the parent directory (ie. one level up).
Install them using dpkg. E.g.:


sudo dpkg -i \
../qgis_1.0preview16_amd64.deb \
../libqgis-gui1_1.0preview16_amd64.deb \
../libqgis-core1_1.0preview16_amd64.deb \
../qgis-plugin-grass_1.0preview16_amd64.deb \
../python-qgis_1.0preview16_amd64.deb



5.11. Running QGIS
==================

Now you can try to run QGIS:
@@ -2228,11 +2275,12 @@ The following people have contributed to this document:
- Juergen Fischer 2007

- OSX Section
- Tim Sutton, 2007
- Tim Sutton 2007
- With special thanks to Tom Elwertowski and William Kyngesburye

- GNU/Linux Section
- Tim Sutton 2006
- Debian package section: Juergen Fischer 2008



0 comments on commit 1ed192a

Please sign in to comment.
You can’t perform that action at this time.