Skip to content
Permalink
Browse files

Revert "debian packaging: disable pdal provider on all dists except u…

…nstable"

As b5e98c3 reverts back to support earlier PDAL versions than 2.2.

This reverts commit a75ff77.
  • Loading branch information
jef-n committed Dec 23, 2020
1 parent e520af3 commit 312e24a0bb7aa1bd32093bd01545757c114c3434
Showing with 3 additions and 6 deletions.
  1. +1 −1 debian/control.in
  2. +1 −1 debian/qgis-providers.install
  3. +1 −4 debian/rules
@@ -71,7 +71,7 @@ Build-Depends:
qtpositioning5-dev,
qttools5-dev-tools,
qttools5-dev,
#sid# libpdal-dev, pdal,
libpdal-dev, pdal,
libprotobuf-dev,
protobuf-compiler,
libzstd-dev,
@@ -20,5 +20,5 @@ usr/lib/qgis/plugins/libvirtuallayerprovider.so
usr/lib/qgis/plugins/libwcsprovider.so
usr/lib/qgis/plugins/libwfsprovider.so
usr/lib/qgis/plugins/libwmsprovider.so
#sid#usr/lib/qgis/plugins/libpdalprovider.so
usr/lib/qgis/plugins/libpdalprovider.so
usr/lib/*/qt?/plugins/sqldrivers/libqsqlspatialite.so
@@ -101,6 +101,7 @@ CMAKE_OPTS := \
-DWITH_QSPATIALITE=TRUE \
-DWITH_3D=TRUE \
-DGEOS_LIBRARY=/usr/lib/$(DEB_BUILD_MULTIARCH)/libgeos_c.so \
-DWITH_PDAL=TRUE \
-DWITH_EPT=TRUE

ifneq ($(SHA),)
@@ -114,10 +115,6 @@ ifeq ($(GRASSVER),7)
-DGRASS_PREFIX7=/usr/lib/$(GRASS)
endif

ifneq (,$(findstring $(DISTRIBUTION),"sid"))
CMAKE_OPTS += -DWITH_PDAL=TRUE
endif

ifneq (,$(findstring $(DISTRIBUTION),"sid buster"))
CMAKE_OPTS += -DPOSTGRES_LIBRARY=/usr/lib/$(DEB_BUILD_MULTIARCH)/libpq.so
endif

0 comments on commit 312e24a

Please sign in to comment.
You can’t perform that action at this time.